openssl: Use mkhash for STAMP_CONFIGURED
authorFlorian Fainelli <f.fainelli@gmail.com>
Wed, 1 Mar 2017 18:48:32 +0000 (10:48 -0800)
committerFlorian Fainelli <f.fainelli@gmail.com>
Thu, 2 Mar 2017 01:19:52 +0000 (17:19 -0800)
The current way of creating a STAMP_CONFIGURED filename for OpenSSL can
lead to an extremely long filename that makes touch unable to create it,
and fail the build.

Use mkhash to produce a hash against OPENSSL_OPTIONS which creates a
shortert stamp file,

Fixes #572

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
package/libs/openssl/Makefile

index 9b6430234e0a5d8ecf5a82af09118a661c756d96..b39e3c6d7afa0bd6a93e9f07d11f31e3598b28db 100644 (file)
@@ -168,7 +168,7 @@ else
   endif
 endif
 
-STAMP_CONFIGURED := $(STAMP_CONFIGURED)_$(subst $(space),_,$(OPENSSL_OPTIONS))
+STAMP_CONFIGURED := $(STAMP_CONFIGURED)_$(shell echo $(OPENSSL_OPTIONS) | mkhash md5)
 
 define Build/Configure
        [ -f $(STAMP_CONFIGURED) ] || { \