ar71xx: add profile and build image for the TEW-712BR
authorGabor Juhos <juhosg@openwrt.org>
Wed, 22 Aug 2012 20:18:44 +0000 (20:18 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 22 Aug 2012 20:18:44 +0000 (20:18 +0000)
SVN-Revision: 33234

target/linux/ar71xx/generic/profiles/trendnet.mk
target/linux/ar71xx/image/Makefile

index 4b1bc1f58c2ef9ed8a9fb6d8ef2bb06b22c57401..c6fe9cf792d0424b22fa306a0cc993e1cb418147 100644 (file)
@@ -37,3 +37,15 @@ define Profile/TEW673GRU/Description
 endef
 
 $(eval $(call Profile,TEW673GRU))
+
+define Profile/TEW712BR
+       NAME:=TRENDNet TEW-712BR
+       PACKAGES:=
+endef
+
+define Profile/TEW712BR/Description
+       Package set optimized for the TRENDNet TEW-712BR.
+endef
+
+$(eval $(call Profile,TEW712BR))
+
index 28c02f61214c93eb3fb24a6106dd1502fbe60f25..3f4fc5d435b9c31c14fa2da3a80c6162d9520f08 100644 (file)
@@ -220,6 +220,18 @@ define Image/Build/Cameo
        fi
 endef
 
+define Image/Build/CameoHornet
+       $(call MkuImageLzma,$(2),$(3) $(4))
+       $(call Sysupgrade/KRuImage,$(1),$(2),$(5),$(6))
+       if [ -e "$(call sysupname,$(1),$(2))" ]; then \
+               mkcameofw -M HORNET -R "DEF" -S $(7) -V "1.99" \
+                       -K $(5) -I $$$$(($(5)+$(6))) \
+                       -k $(KDIR_TMP)/vmlinux-$(2).uImage \
+                       -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+                       -o $(call factoryname,$(1),$(2)); \
+       fi
+endef
+
 cameo913x_mtdlayout=mtdparts=spi0.0:128k(u-boot)ro,64k(config)ro,960k(kernel),2880k(rootfs),64k(art)ro,3840k@0x30000(firmware)
 define Image/Build/Cameo913x
        $(call Image/Build/Cameo,$(1),$(2),$(3),$(cameo913x_mtdlayout),983040,2949120,$(4))
@@ -238,6 +250,15 @@ define Image/Build/Cameo7240/initramfs
        $(call MkuImageLzma/initramfs,$(2),$(3) $(cameo7240_mtdlayout))
 endef
 
+cameo933x_mtdlayout=mtdparts=spi0.0:64k(u-boot)ro,64k(art)ro,64k(mac)ro,64k(nvram)ro,192k(language)ro,896k(kernel),2752k(rootfs),3648k@0x70000(firmware)
+define Image/Build/Cameo933x
+       $(call Image/Build/CameoHornet,$(1),$(2),$(3),$(cameo933x_mtdlayout),917504,2818048,$(4))
+endef
+
+define Image/Build/Cameo933x/initramfs
+       $(call MkuImageLzma/initramfs,$(2),$(3) $(cameo933x_mtdlayout))
+endef
+
 define Image/Build/Ath
        $(call Sysupgrade/$(7),$(1),$(2),$(5),$(6))
        if [ -e "$(call sysupname,$(1),$(2))" ]; then \
@@ -818,6 +839,12 @@ define Image/Build/Profile/TEW652BRP
        $(call Image/Build/Template/$(fs_squash)/$(1),Cameo913x,tew-652brp-recovery,$(tew652brp_cmdline),"AP81-AR9130-RT-070614-02")
 endef
 
+tew712br_cmdline=board=TEW-712BR console=ttyATH0,115200
+define Image/Build/Profile/TEW712BR
+       $(call Image/Build/Template/$(fs_squash)/$(1),Cameo933x,tew-712br,$(tew712br_cmdline),"HORNET-RT-TEW712BR-3")
+endef
+
+
 a05rbw300n_cmdline=board=TEW-632BRP console=ttyS0,115200
 define Image/Build/Profile/A02RBW300N
        $(call Image/Build/Template/$(fs_squash)/$(1),Cameo913x,a02-rb-w300n,$(a05rbw300n_cmdline),"AP81-AR9130-RT-070614-03")
@@ -1120,6 +1147,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TEW632BRP,$(1))
        $(call Image/Build/Profile/TEW652BRP,$(1))
        $(call Image/Build/Profile/TEW673GRU,$(1))
+       $(call Image/Build/Profile/TEW712BR,$(1))
        $(call Image/Build/Profile/TLMR11U,$(1))
        $(call Image/Build/Profile/TLMR3020,$(1))
        $(call Image/Build/Profile/TLMR3040,$(1))