curl: add config option for NTLM support
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Apr 2016 12:51:41 +0000 (12:51 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Apr 2016 12:51:41 +0000 (12:51 +0000)
Signed-off-by: Dirk Feytons <dirk.feytons@gmail.com>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 49183

package/network/utils/curl/Config.in
package/network/utils/curl/Makefile

index f41307a97042381adbcb5ea7294a98cde05f7dda..14d2047301f7a057bf96302d735c409597da7463 100644 (file)
@@ -154,4 +154,9 @@ config LIBCURL_VERBOSE
        bool "Enable verbose error strings"
        default n
 
+config LIBCURL_NTLM
+       bool "Enable NTLM support"
+       depends LIBCURL_CRYPTO_AUTH && !LIBCURL_NOSSL
+       default n
+
 endif
index eada1aa5967be37d8aa6af4d8c5f726a3f14a353..319c0b710d2b4ead9492ab2bd6cb5c61c2fd7870 100644 (file)
@@ -65,7 +65,8 @@ PKG_CONFIG_DEPENDS:= \
   CONFIG_LIBCURL_THREADED_RESOLVER \
   CONFIG_LIBCURL_TLS_SRP \
   CONFIG_LIBCURL_UNIX_SOCKETS \
-  CONFIG_LIBCURL_VERBOSE
+  CONFIG_LIBCURL_VERBOSE \
+  CONFIG_LIBCURL_NTLM
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -99,6 +100,7 @@ define Package/libcurl/config
 endef
 
 TARGET_CFLAGS += $(FPIC)
+TARGET_CPPFLAGS += $(if $(CONFIG_LIBCURL_NTLM),,-DCURL_DISABLE_NTLM)
 
 CONFIGURE_ARGS += \
        --disable-debug \