brcm47xx: fix USB driver choice for Asus WL-500W
authorMirko Parthey <mirko.parthey@web.de>
Tue, 14 Feb 2017 14:05:09 +0000 (15:05 +0100)
committerRafał Miłecki <rafal@milecki.pl>
Wed, 15 Feb 2017 22:43:19 +0000 (23:43 +0100)
BCM4704 SoC has only USB 1.1 core:
ssb: Core 3 found: USB 1.1 Hostdev (cc 0x808, rev 0x03, vendor 0x4243)
but this device actually comes with two USB 2.0 ports.

It appears embedded controller isn't used but instead there are two PCI
attached controllers (next to the BCM4321 wireless card):
1106:3038 VT82xx/62xx UHCI USB 1.1 Controller
1106:3104 USB 2.0

Choose a set of USB drivers which actually support this hardware.

Signed-off-by: Mirko Parthey <mirko.parthey@web.de>
Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/brcm47xx/image/Makefile

index 1bf577e159a1741ce203f3bb8f1e32e376dd360c..8c681ac345a18e70a86d299c6cf327cc89ca4288 100644 (file)
@@ -300,7 +300,7 @@ TARGET_DEVICES += asus-wl-500gp-v2
 
 define Device/asus-wl-500w
   DEVICE_TITLE := Asus WL-500W
-  DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
+  DEVICE_PACKAGES := kmod-b43 kmod-usb-uhci kmod-usb2-pci
   $(Device/asus)
   PRODUCTID := "WL500W      "
 endef