oxnas: use ARM BCJ filter for XZ decompression
authorJohn Crispin <john@openwrt.org>
Thu, 11 Dec 2014 20:41:51 +0000 (20:41 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 11 Dec 2014 20:41:51 +0000 (20:41 +0000)
Restoring the config for kernel 3.14 didn't contain that change already
made to config-3.18.
It is needed to make squashfs in the kernel match the compression settings
for ARCH=arm in the framework.
If set to ARMTHUMB, boot fails due to squashfs being unreadable if the
filesystem was generated for wth ARM BCJ filter.

in include/image.mk:    BCJ_FILTER:=-Xbcj $(LINUX_KARCH)
Thus the ARM filter is used for all ARM targets.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 43640

target/linux/oxnas/config-3.14

index 727d81e2f4247fc09fb6a45a655b1decc8a35a0d..086f870cea1387edc18227871388ec5bf7138981 100644 (file)
@@ -339,7 +339,7 @@ CONFIG_VM_EVENT_COUNTERS=y
 CONFIG_WATCHDOG_CORE=y
 CONFIG_WATCHDOG_NOWAYOUT=y
 CONFIG_XPS=y
-CONFIG_XZ_DEC_ARMTHUMB=y
+CONFIG_XZ_DEC_ARM=y
 CONFIG_XZ_DEC_BCJ=y
 CONFIG_ZBOOT_ROM_BSS=0
 CONFIG_ZBOOT_ROM_TEXT=0