kernel: mark modules that won't build on 2.6.28 as broken
authorNicolas Thill <nico@openwrt.org>
Mon, 2 Feb 2009 15:48:52 +0000 (15:48 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 2 Feb 2009 15:48:52 +0000 (15:48 +0000)
SVN-Revision: 14356

package/kernel/modules/block.mk
package/kernel/modules/netfilter.mk

index 46e820c146bd907c3940620a235dfb74eaf5f784..2c720eba10a43ea4a5f917c681436ec9f7748b0b 100644 (file)
@@ -131,10 +131,11 @@ endef
 $(eval $(call KernelPackage,ata-via-sata))
 
 
+# XXX: broken on 2.6.28 due to module name/path changes
 define KernelPackage/ide-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=IDE (ATA/ATAPI) device support
-  DEPENDS:=@PCI_SUPPORT
+  DEPENDS:=@PCI_SUPPORT @LINUX_2_6_28:BROKEN
   KCONFIG:= \
        CONFIG_IDE \
        CONFIG_IDE_GENERIC \
index 0d86adffc3377f2bac2fa133339584e0ddf181d1..c17c8a8def3116c673ef0e7f61af1d8565607917 100644 (file)
@@ -328,13 +328,14 @@ endef
 $(eval $(call KernelPackage,ipt-ipset))
 
 
+# XXX: broken on 2.6.28 to xt_CHAOS module
 define KernelPackage/ipt-extra
   SUBMENU:=$(NF_MENU)
   TITLE:=Extra modules
   KCONFIG:=$(KCONFIG_IPT_EXTRA)
   FILES:=$(foreach mod,$(IPT_EXTRA-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_EXTRA-m)))
-  DEPENDS:= kmod-ipt-core
+  DEPENDS:= kmod-ipt-core @LINUX_2_6_28:BROKEN
 endef
 
 define KernelPackage/ipt-extra/description