ramips: mt7621: switch to 24kc
authorJonas Gorski <jonas.gorski@gmail.com>
Sun, 21 Aug 2016 17:23:13 +0000 (19:23 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 23 Aug 2016 09:55:32 +0000 (11:55 +0200)
1004kc is just a SMP capable 34kc, and GCC treats 24kc and 34kc exactly
the same and will generate identical code, so there is no need to tune
to 1004kc instead of 24kc.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
include/target.mk
target/linux/ramips/mt7621/target.mk

index ed15d04984dc178fcdf7340e42089059e162d95e..4b01237a4d1806c383c8a5942299a5ae0e5e1cc9 100644 (file)
@@ -168,7 +168,6 @@ ifeq ($(DUMP),1)
     CPU_CFLAGS_mips64 = -mips64 -mtune=mips64 -mabi=64
     CPU_CFLAGS_24kc = -mips32r2 -mtune=24kc
     CPU_CFLAGS_74kc = -mips32r2 -mtune=74kc
-    CPU_CFLAGS_1004kc = -mips32r2 -mtune=1004kc
     CPU_CFLAGS_octeon = -march=octeon -mabi=64
   endif
   ifeq ($(ARCH),i386)
index edf26203d03af17c147c4f314475594529875cf6..121761f45f544aa30436f66b4180a3ec21344321 100644 (file)
@@ -5,7 +5,7 @@
 SUBTARGET:=mt7621
 BOARDNAME:=MT7621 based boards
 FEATURES+=usb rtc nand
-CPU_TYPE:=1004kc
+CPU_TYPE:=24kc
 
 DEFAULT_PACKAGES += kmod-mt76