mac80211: add dependency of PACKAGE_MAC80211_DEBUGFS
authorFelix Fietkau <nbd@openwrt.org>
Fri, 4 Jan 2013 17:41:23 +0000 (17:41 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 4 Jan 2013 17:41:23 +0000 (17:41 +0000)
I wanted to use some statistics from /sys/kernel/debug/ieee80211,
so I enabled PACKAGE_MAC80211_DEBUGFS.  But I could not use it,
because CONFIG_KERNEL_DEBUG_FS was not set and it's a little bit
hidden. After manually setting CONFIG_KERNEL_DEBUG_FS to y,
everything was fine. This patch automatically selects
CONFIG_KERNEL_DEBUG_FS if PACKAGE_MAC80211_DEBUGFS is set.

Additionally, the help text says "Say N unless you know you need this.",
but it's default y. This help text is copied verbatim from the
kernel's Kconfig and not true for us. So remove this part of the
help text

Signed-off-by: Stefan Hellermann <stefan@the2masters.de>
SVN-Revision: 35014

package/mac80211/Makefile

index f57d30353c12af3c673877422a08b5ba15a5492c..ac6019362403ddeadc3e755def45afdf962f40f8 100644 (file)
@@ -84,13 +84,12 @@ define KernelPackage/mac80211/config
 
        config PACKAGE_MAC80211_DEBUGFS
                bool "Export mac80211 internals in DebugFS"
+               select KERNEL_DEBUG_FS
                default y
                help
                  Select this to see extensive information about
                  the internal state of mac80211 in debugfs.
 
-                 Say N unless you know you need this.
-
        config PACKAGE_MAC80211_MESH
                bool "Enable 802.11s mesh support"
                default y