include: relax umask check
authorJo-Philipp Wich <jo@mein.io>
Tue, 4 Oct 2016 12:05:56 +0000 (14:05 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 4 Oct 2016 12:07:37 +0000 (14:07 +0200)
For now we only want to ensure that the group permission mask is permissive
enough to not clobber required permissions on the rootfs, so allow less
strict masks as well.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/prereq-build.mk

index c3b88db6271631e6fb5a8f720825fcb547dd7d67..4a0509ac00380a272821158b22a29abd0150f511 100644 (file)
@@ -26,7 +26,7 @@ $(eval $(call TestHostCommand,case-sensitive-fs, \
 
 $(eval $(call TestHostCommand,proper-umask, \
        Please build with umask 022 - other values produce broken packages, \
-       umask | grep -xF 0022))
+       umask | grep -xE 00[012][012]))
 
 $(eval $(call SetupHostCommand,gcc, \
        Please install the GNU C Compiler (gcc), \