ar71xx: PowerCloud CAP324 image generation
authorFelix Fietkau <nbd@openwrt.org>
Sat, 19 Dec 2015 11:27:39 +0000 (11:27 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 19 Dec 2015 11:27:39 +0000 (11:27 +0000)
Image generation (and mtd partition) part of support for
PowerCloud CAP324 Cloud AP. The CAP324 Cloud AP is a device sold by
PowerCloud Systems who's stock firmware (CloudCommand) provides
'cloud' based managment of large numbers of access points.

The CAP324 is a dual-band 802.11n wireless access point with 16MB flash
and 128MB RAM and single gigabit ethernet port.  It can be powered via
PoE or a power adaptor.

Signed-off-by: Daniel Dickinson <openwrt@daniel.thecshore.com>
SVN-Revision: 47941

target/linux/ar71xx/generic/profiles/pcs.mk
target/linux/ar71xx/image/Makefile

index 1399ef4233be13e0ba10398adba9118ab2955ff8..1466e5282a146be5be6febd206e57cd7dc9b4288 100644 (file)
@@ -27,3 +27,23 @@ define Profile/DLRTDEV01/Description
 endef
 
 $(eval $(call Profile,DLRTDEV01))
 endef
 
 $(eval $(call Profile,DLRTDEV01))
+
+define Profile/CAP324
+       NAME:=PowerCloud CAP324 Cloud AP
+       PACKAGES:=uboot-envtools
+endef
+
+define Profile/CAP324/Description
+       Package set optimized for the PowerCloud Systems CAP324 Cloud AP
+
+       The CAP324 Cloud AP is a device sold by PowerCloud Systems 
+       who's stock firmware (CloudCommand) provides 'cloud' based
+       managment of large numbers of access points.    
+
+       The CAP324 is a dual-band 802.11n wireless access point with 16MB
+       flash and 128MB RAM and single gigabit ethernet port.  It can be 
+       powered via PoE or a wall wart.
+endef
+
+$(eval $(call Profile,CAP324))
+
index 10de2237d591a7ea2a8c0b65c20785c400ac9896..5783221b1da3543f22b52a31c913cb42604f4fc4 100644 (file)
@@ -392,6 +392,24 @@ define Device/tl-wdr7500-v3
 endef
 TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2 tl-wdr7500-v3
 
 endef
 TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2 tl-wdr7500-v3
 
+define Device/cap324
+  BOARDNAME := CAP324
+  DEVICE_PROFILE := CAP324
+  IMAGE_SIZE = 15296k
+  MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,15296k(firmware),640k(certs),64k(nvram),64k(art)
+endef
+
+TARGET_DEVICES += cap324
+
+define Device/cap324-nocloud
+  BOARDNAME := CAP324
+  DEVICE_PROFILE := CAP324
+  IMAGE_SIZE = 16000k
+  MTDPARTS = spi0.0:256k(u-boot),64k(u-boot-env)ro,16000k(firmware),64k(art)
+endef
+
+TARGET_DEVICES += cap324-nocloud
+
 define Device/antminer-s1
     $(Device/tplink-8mlzma)
     BOARDNAME := ANTMINER-S1
 define Device/antminer-s1
     $(Device/tplink-8mlzma)
     BOARDNAME := ANTMINER-S1