include: use anchored patterns for dependency checking
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 29 Jan 2015 21:59:17 +0000 (21:59 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 29 Jan 2015 21:59:17 +0000 (21:59 +0000)
Anchor search pattern when testing dependencies, otherwise the check may
succeed in cases where it shouldn't, e.g. when matching "udp_tunnel.ko"
against "ip6_udp_tunnel.ko".

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44207

include/package-ipkg.mk

index 77eaeb824f9b67ff3966dfbffa3a3440edfa8162..815aef093a2196906490c5c2eb0478550964c087 100644 (file)
@@ -66,7 +66,7 @@ ifneq ($(PKG_NAME),toolchain)
                                XARGS="$(XARGS)"; \
                        $(SCRIPT_DIR)/gen-dependencies.sh "$$(IDIR_$(1))"; \
                ) | while read FILE; do \
-                       grep -q "$$$$FILE" $(PKG_INFO_DIR)/$(1).provides || \
+                       grep -qE "^$$$$FILE$$$$" $(PKG_INFO_DIR)/$(1).provides || \
                                echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
                done; \
                if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \