package/kernel: move hwmon-vid into a separate package
authorGabor Juhos <juhosg@openwrt.org>
Wed, 9 May 2012 10:48:33 +0000 (10:48 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 9 May 2012 10:48:33 +0000 (10:48 +0000)
SVN-Revision: 31655

package/kernel/modules/hwmon.mk

index 61b5b3d602f75e616ed5eca04f471c834b4c6a5c..62eceb913fffa25976abd04092228ba302b6e759 100644 (file)
@@ -30,6 +30,21 @@ define AddDepends/hwmon
   DEPENDS:=kmod-hwmon-core $(1)
 endef
 
+define KernelPackage/hwmon-vid
+  TITLE:=VID/VRM/VRD voltage conversion module.
+  KCONFIG:=CONFIG_HWMON_VID
+  FILES:=$(LINUX_DIR)/drivers/hwmon/hwmon-vid.ko
+  AUTOLOAD:=$(call AutoLoad,41,hwmon-vid)
+  $(call AddDepends/hwmon,)
+endef
+
+define KernelPackage/hwmon-vid/description
+  VID/VRM/VRD voltage conversion module for hardware monitoring.
+endef
+
+$(eval $(call KernelPackage,hwmon-vid))
+
+
 define KernelPackage/hwmon-lm63
   TITLE:=LM63/64 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM63
@@ -119,14 +134,10 @@ $(eval $(call KernelPackage,hwmon-sht21))
 
 define KernelPackage/hwmon-pc87360
   TITLE:=PC87360 monitoring support
-  KCONFIG:= \
-       CONFIG_SENSORS_PC87360 \
-       CONFIG_HWMON_VID
-  FILES:= \
-       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.ko \
-       $(LINUX_DIR)/drivers/hwmon/pc87360.ko
-  AUTOLOAD:=$(call AutoLoad,50,hwmon-vid pc87360)
-  $(call AddDepends/hwmon,@TARGET_x86)
+  KCONFIG:=CONFIG_SENSORS_PC87360
+  FILES:=$(LINUX_DIR)/drivers/hwmon/pc87360.ko
+  AUTOLOAD:=$(call AutoLoad,50,pc87360)
+  $(call AddDepends/hwmon,@TARGET_x86 +kmod-hwmon-vid)
 endef
 
 define KernelPackage/hwmon-pc87360/description
@@ -138,14 +149,10 @@ $(eval $(call KernelPackage,hwmon-pc87360))
 
 define KernelPackage/hwmon-w83627hf
   TITLE:=Winbond W83627HF monitoring support
-  KCONFIG:= \
-       CONFIG_SENSORS_W83627HF \
-       CONFIG_HWMON_VID
-  FILES:= \
-       $(LINUX_DIR)/drivers/hwmon/hwmon-vid.ko \
-       $(LINUX_DIR)/drivers/hwmon/w83627hf.ko
-  AUTOLOAD:=$(call AutoLoad,50,hwmon-vid w83627hf)
-$(call AddDepends/hwmon,@TARGET_rdc||TARGET_x86)
+  KCONFIG:=CONFIG_SENSORS_W83627HF
+  FILES:=$(LINUX_DIR)/drivers/hwmon/w83627hf.ko
+  AUTOLOAD:=$(call AutoLoad,50,w83627hf)
+$(call AddDepends/hwmon,@TARGET_rdc||TARGET_x86 +kmod-hwmon-vid)
 endef
 
 define KernelPacakge/hwmon-w83627hf/description