busybox: fix broken default for FEATURE_IP_ROUTE_DIR (#21845)
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 12 Feb 2016 19:46:31 +0000 (19:46 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 12 Feb 2016 19:46:31 +0000 (19:46 +0000)
Changeset r47775 introduced a wrong default value "n" for the ip applets
config search path, breaking the handling of named routing tables and other
objects having alias configurations.

Fix the issue by providing a proper default value aligned with the value
used by full iproute2.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 48716

package/utils/busybox/Config-defaults.in
package/utils/busybox/Makefile

index 3df4cda4fbdebee0c4adfe47da86aa8842df2ce8..ee42fa12f02c1c01e157b2ff923e9490ea3d8cd3 100644 (file)
@@ -2172,7 +2172,7 @@ config BUSYBOX_DEFAULT_FEATURE_IP_ROUTE
        default y
 config BUSYBOX_DEFAULT_FEATURE_IP_ROUTE_DIR
        string
        default y
 config BUSYBOX_DEFAULT_FEATURE_IP_ROUTE_DIR
        string
-       default "n"
+       default "/etc/iproute2"
 config BUSYBOX_DEFAULT_FEATURE_IP_TUNNEL
        bool
        default n
 config BUSYBOX_DEFAULT_FEATURE_IP_TUNNEL
        bool
        default n
index 95e785bfe626a48b622f81030bb6454789f8ce0c..6a55d5687c53cf9d8d07ac81168bc9177eeb0caf 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.24.1
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.24.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2