ubifs: enable building modular images
authorLuka Perkov <luka@openwrt.org>
Sat, 12 Oct 2013 21:44:48 +0000 (21:44 +0000)
committerLuka Perkov <luka@openwrt.org>
Sat, 12 Oct 2013 21:44:48 +0000 (21:44 +0000)
Now it is possible to build ubi/ubifs images for only selected boards inside
single target.

Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38375

include/image.mk
target/linux/kirkwood/image/Makefile
target/linux/xburst/image/Makefile

index f5f1c8fb54fe41ff09ba2e3952c632daf3f1894b..aa3bf27de06d1e856a294b9e15a816caf9f97e33 100644 (file)
@@ -35,7 +35,7 @@ ifeq ($(CONFIG_JFFS2_LZMA),y)
   JFFS2OPTS += -X lzma --compression-mode=size
 endif
 ifneq ($(CONFIG_JFFS2_RTIME),y)
-  JFFS2OPTS +=  -x rtime
+  JFFS2OPTS += -x rtime
 endif
 ifneq ($(CONFIG_JFFS2_ZLIB),y)
   JFFS2OPTS += -x zlib
@@ -115,7 +115,8 @@ endif
 
 ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
     define Image/mkfs/ubifs
-               $(CP) ./ubinize.cfg $(KDIR)
+
+        ifdef UBIFS_OPTS
                $(STAGING_DIR_HOST)/bin/mkfs.ubifs \
                        $(UBIFS_OPTS) \
                        $(if $(CONFIG_TARGET_UBIFS_FREE_SPACE_FIXUP),--space-fixup) \
@@ -125,10 +126,19 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
                        --jrn-size=$(CONFIG_TARGET_UBIFS_JOURNAL_SIZE) \
                        -o $(KDIR)/root.ubifs \
                        -d $(TARGET_DIR)
-               $(call Image/Build,ubifs)
-               (cd $(KDIR); \
-               $(STAGING_DIR_HOST)/bin/ubinize $(UBINIZE_OPTS) -o $(KDIR)/root.ubi ubinize.cfg)
-               $(call Image/Build,ubi)
+        endif
+       $(call Image/Build,ubifs)
+
+        ifdef UBI_OPTS
+               $(CP) ./ubinize.cfg $(KDIR)
+               ( cd $(KDIR); \
+               $(STAGING_DIR_HOST)/bin/ubinize \
+                       $(UBI_OPTS) \
+                       -o $(KDIR)/root.ubi \
+                       ubinize.cfg \
+               )
+        endif
+       $(call Image/Build,ubi)
     endef
 endif
 
index b3d25f56b016eb914a6afc5222a1180aa5282d64..c63f606c69f445c7df085f2e4472d3c1a063367b 100644 (file)
@@ -8,8 +8,6 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 NAND_BLOCKSIZE := 2048:128k
-UBIFS_OPTS := -m 2048 -e 126KiB -c 4096 -U
-UBINIZE_OPTS := -m 2048 -p 128KiB -s 512
 
 define Image/BuildKernel
        $(CP) $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
@@ -60,4 +58,18 @@ define Image/Build/squashfs
        ) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
 endef
 
+define Image/Build/ubifs
+
+ ifdef UBIFS_OPTS
+       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
+ endif
+endef
+
+define Image/Build/ubi
+
+ ifdef UBI_OPTS
+       $(call Image/Build/ubifs,$(1))
+ endif
+endef
+
 $(eval $(call BuildImage))
index 9c03b38092317fa48a16bf887cd0a6c0cc10c434..0de5560c961e0ee3f96486b6f2ab468d3d8943ec 100644 (file)
@@ -10,11 +10,11 @@ include $(INCLUDE_DIR)/image.mk
 JFFS2_BLOCKSIZE=256k 512k
 
 ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
+UBI_OPTS = -m 4096 -p 512KiB
 UBIFS_OPTS = -m 4096 -e 516096 -c 4095
-UBINIZE_OPTS = -m 4096 -p 512KiB
 else
+UBI_OPTS = -m 2048 -p 128KiB -s 512
 UBIFS_OPTS = -m 2048 -e 126KiB -c 4096
-UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
 endif
 
 UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage.bin