make hotplug2 use the build system cflags
authorFelix Fietkau <nbd@openwrt.org>
Mon, 25 Jun 2007 06:30:36 +0000 (06:30 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 25 Jun 2007 06:30:36 +0000 (06:30 +0000)
SVN-Revision: 7720

package/hotplug2/Makefile
package/hotplug2/patches/110-depend_fix.patch [new file with mode: 0644]

index 6b69bac73349a28b237949eed497ada697dc0da1..bf7c8c6b090ae51bdddb8ee926a3c1e65c7a5b6b 100644 (file)
@@ -29,6 +29,7 @@ define Package/hotplug2/description
 Hotplug2 is a trivial replacement of some of the UDev functionality
 in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
 endef
+MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS)"
 
 define Package/hotplug2/install
        $(INSTALL_DIR) $(1)/etc
diff --git a/package/hotplug2/patches/110-depend_fix.patch b/package/hotplug2/patches/110-depend_fix.patch
new file mode 100644 (file)
index 0000000..762b26f
--- /dev/null
@@ -0,0 +1,13 @@
+Index: hotplug2-0.9/common.mak
+===================================================================
+--- hotplug2-0.9.orig/common.mak       2007-06-25 08:08:59.320226312 +0200
++++ hotplug2-0.9/common.mak    2007-06-25 08:09:03.541584568 +0200
+@@ -10,7 +10,7 @@
+ .PHONY: all clean dep install install-recursive clean-recursive \
+       dep-recursive all-recursive
+-MAKEDEP=-gcc $(CFLAGS) -MM $(wildcard *.c *.cc) > .depend
++MAKEDEP=-$(CC) $(CFLAGS) -MM $(wildcard *.c *.cc) > .depend
+ dep: dep-recursive
+       $(MAKEDEP)
+ .depend: