kernel/modules: Add w1-master-ds2490 module (#8779)
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Wed, 2 Feb 2011 18:17:04 +0000 (18:17 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Wed, 2 Feb 2011 18:17:04 +0000 (18:17 +0000)
SVN-Revision: 25311

package/kernel/modules/w1.mk

index 47d8f3682e160d0c0b3c92121083a8970699bc9e..c4ab6165cc69c667d5a6f07e5cfa2ddb742e5208 100644 (file)
@@ -48,6 +48,20 @@ endef
 
 $(eval $(call KernelPackage,w1-master-gpio))
 
+define KernelPackage/w1-master-ds2490
+  TITLE:=DS2490 1-wire usb bus master driver
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core
+  KCONFIG:=CONFIG_W1_MASTER_DS2490
+  FILES:=$(W1_MASTERS_DIR)/ds2490.ko
+  AUTOLOAD:=$(call AutoLoad,60,ds2490)
+  $(call AddDepends/w1)
+endef
+define KernelPackage/w1-master-ds2490/description
+  Kernel module for the DS2490 usb 1-wire bus master driver
+endef
+
+$(eval $(call KernelPackage,w1-master-ds2490))
 
 #
 # 1-wire slaves