Use wildcards to copy grub stage files, will cover both i386-pc and i386-openwrt...
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 10 Jan 2009 23:12:21 +0000 (23:12 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 10 Jan 2009 23:12:21 +0000 (23:12 +0000)
SVN-Revision: 13963

target/linux/x86/image/Makefile

index a740b0b63c32080bdf21c99598e58361887d3420..4d766399238170607e84dee4db7c9f3b759b827e 100644 (file)
@@ -49,9 +49,9 @@ ifneq ($(HOST_OS),Darwin)
   define Image/Prepare/grub
        # for the image builder
        $(CP) \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-openwrt/stage1 \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-openwrt/stage2 \
-               $(STAGING_DIR_HOST)/usr/lib/grub/i386-openwrt/e2fs_stage1_5 \
+               $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/stage1 \
+               $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/stage2 \
+               $(STAGING_DIR_HOST)/usr/lib/grub/i386-*/e2fs_stage1_5 \
                $(KDIR)/
   endef
 else