Fix dependencies and build (#1849)
authorFlorian Fainelli <florian@openwrt.org>
Mon, 11 Jun 2007 08:08:59 +0000 (08:08 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 11 Jun 2007 08:08:59 +0000 (08:08 +0000)
SVN-Revision: 7555

package/spca5xx-view/Makefile

index 772655c6fadfd9d58774e71d4cd97f6c2838922c..263896e1cf866a1137fc2420b9d488085f38f5e6 100644 (file)
@@ -24,14 +24,14 @@ define Package/spca5xx-view
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=spca5xx streaming applicaton
-  DEPENDS:=kmod-spca5xx-le libpthread
+  DEPENDS:=+kmod-spca5xx-le +libpthread
   DESCRIPTION:=\
        This package contains a streaming daemon for spca5xx based webcams 
   URL:=http://www.acmesystems.it
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)/servfox/ CFLAGS=$(TARTGET_CFLAGS) CC=$(TARGET_CC) 
+       $(MAKE) -C $(PKG_BUILD_DIR)/servfox/ CFLAGS=$(TARTGET_CFLAGS) CC=$(TARGET_CC) all
        $(MAKE) -C $(PKG_BUILD_DIR)/servfox/ PREFIX="$(PKG_INSTALL_DIR)" install
 endef