toolchain/gcc: upgrade Linaro GCC 4.9 to 4.9-2015.03
authorImre Kaloz <kaloz@openwrt.org>
Thu, 11 Jun 2015 11:57:11 +0000 (11:57 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Thu, 11 Jun 2015 11:57:11 +0000 (11:57 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 45944

16 files changed:
toolchain/gcc/common.mk
toolchain/gcc/patches/4.9-linaro/010-documentation.patch
toolchain/gcc/patches/4.9-linaro/200-musl_config.patch
toolchain/gcc/patches/4.9-linaro/202-musl_mips.patch
toolchain/gcc/patches/4.9-linaro/203-musl_powerpc.patch
toolchain/gcc/patches/4.9-linaro/204-musl_sh.patch
toolchain/gcc/patches/4.9-linaro/205-musl_x86.patch
toolchain/gcc/patches/4.9-linaro/209-musl_libstdc++.patch
toolchain/gcc/patches/4.9-linaro/220-musl_mips_softfloat.patch
toolchain/gcc/patches/4.9-linaro/221-musl_mips64.patch
toolchain/gcc/patches/4.9-linaro/800-arm_v5te_no_ldrd_strd.patch
toolchain/gcc/patches/4.9-linaro/870-ppc_no_crtsavres.patch
toolchain/gcc/patches/4.9-linaro/910-mbsd_multi.patch
toolchain/gcc/patches/4.9-linaro/920-specs_nonfatal_getenv.patch
toolchain/gcc/patches/4.9-linaro/930-fix-mips-noexecstack.patch
toolchain/gcc/patches/4.9-linaro/940-no-clobber-stamp-bits.patch

index 67263cf34c55c2f250bf09140053bb781c22624d..d07f607c47ee28515cbfc4d8ee4208749df30bf0 100644 (file)
@@ -42,11 +42,11 @@ ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
       PKG_COMP:=xz
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.9-linaro")
-      LINARO_RELEASE:=14.10
-      PKG_REV:=4.9-2014.10
-      PKG_VERSION:=4.9.2
+      LINARO_RELEASE:=15.03
+      PKG_REV:=4.9-2015.03
+      PKG_VERSION:=4.9.3
       PKG_VERSION_MAJOR:=4.9
-      PKG_MD5SUM:=230da25b1e7661a8659eb770c5c88442
+      PKG_MD5SUM:=f9d256d120adfbb45dd3e2d22b70cba9
       PKG_COMP:=xz
     endif
     ifneq ($(LINARO_RELEASE),)
index b8adce838f59e59f03a016e63a667e69aa906382..9f17b64da9edaee7b6675d64c1da76b066dc48ef 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/Makefile.in
 +++ b/gcc/Makefile.in
-@@ -2842,18 +2842,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
+@@ -2847,18 +2847,10 @@ doc/gcc.info: $(TEXI_GCC_FILES)
  doc/gccint.info: $(TEXI_GCCINT_FILES)
  doc/cppinternals.info: $(TEXI_CPPINT_FILES)
  
index ce8865fa82220820152d21e4a8042bb27bb32948..f7c8adadc2fa1143817f1f1f78212cca67f2e5db 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/config.gcc
 +++ b/gcc/config.gcc
-@@ -594,7 +594,7 @@ case ${target} in
+@@ -595,7 +595,7 @@ case ${target} in
  esac
  
  # Common C libraries.
@@ -9,7 +9,7 @@
  
  # 32-bit x86 processors supported by --with-arch=.  Each processor
  # MUST be separated by exactly one space.
-@@ -719,6 +719,9 @@ case ${target} in
+@@ -720,6 +720,9 @@ case ${target} in
      *-*-*uclibc*)
        tm_defines="$tm_defines DEFAULT_LIBC=LIBC_UCLIBC"
        ;;
index 2a8836e8f6df89e115893838f7db2b004f267ad6..06d25d52e444e8473371f906bb0391ca85a790ec 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/config/mips/linux.h
 +++ b/gcc/config/mips/linux.h
-@@ -23,3 +23,10 @@ along with GCC; see the file COPYING3.  
+@@ -23,3 +23,10 @@ along with GCC; see the file COPYING3.
  #undef UCLIBC_DYNAMIC_LINKER
  #define UCLIBC_DYNAMIC_LINKER \
    "%{mnan=2008:/lib/ld-uClibc-mipsn8.so.0;:/lib/ld-uClibc.so.0}"
index 93087bbe198822f7e5cca945506e5a0ddeb34b91..4340c5fd2f45846eed6ce270bfc34a96686121e4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/config.gcc
 +++ b/gcc/config.gcc
-@@ -2334,6 +2334,10 @@ powerpc*-*-linux*)
+@@ -2344,6 +2344,10 @@ powerpc*-*-linux*)
            powerpc*-*-linux*paired*)
                tm_file="${tm_file} rs6000/750cl.h" ;;
        esac
@@ -13,7 +13,7 @@
        fi
 --- a/gcc/config/rs6000/linux64.h
 +++ b/gcc/config/rs6000/linux64.h
-@@ -375,17 +375,21 @@ extern int dot_symbols;
+@@ -371,17 +371,21 @@ extern int dot_symbols;
  #endif
  #define UCLIBC_DYNAMIC_LINKER32 "/lib/ld-uClibc.so.0"
  #define UCLIBC_DYNAMIC_LINKER64 "/lib/ld64-uClibc.so.0"
@@ -41,7 +41,7 @@
  #if (TARGET_DEFAULT & MASK_LITTLE_ENDIAN)
 --- a/gcc/config/rs6000/secureplt.h
 +++ b/gcc/config/rs6000/secureplt.h
-@@ -18,3 +18,4 @@ along with GCC; see the file COPYING3.  
+@@ -18,3 +18,4 @@ along with GCC; see the file COPYING3.
  <http://www.gnu.org/licenses/>.  */
  
  #define CC1_SECURE_PLT_DEFAULT_SPEC "-msecure-plt"
index 9a50c227e820bc5242cdefbe37084fbc7f51d447..dfb5b5174631dd3a510bfb317b765d23b30118d1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/config/sh/linux.h
 +++ b/gcc/config/sh/linux.h
-@@ -43,7 +43,14 @@ along with GCC; see the file COPYING3.  
+@@ -43,7 +43,14 @@ along with GCC; see the file COPYING3.
  
  #define TARGET_ASM_FILE_END file_end_indicate_exec_stack
  
index 9a251133190f80c2756d0e7cb4def33b060662d2..d167105c0062c29df55daf16a244b3d838ab809b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/config/i386/linux.h
 +++ b/gcc/config/i386/linux.h
-@@ -21,3 +21,4 @@ along with GCC; see the file COPYING3.  
+@@ -21,3 +21,4 @@ along with GCC; see the file COPYING3.
  
  #define GNU_USER_LINK_EMULATION "elf_i386"
  #define GLIBC_DYNAMIC_LINKER "/lib/ld-linux.so.2"
index 6643935b180ab34e92cd087fd1d1c48a6278c40f..00d5d313db7fca17fa47b59926b14f67e15678f8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/libstdc++-v3/configure.host
 +++ b/libstdc++-v3/configure.host
-@@ -264,6 +264,13 @@ case "${host_os}" in
+@@ -263,6 +263,13 @@ case "${host_os}" in
      os_include_dir="os/bsd/freebsd"
      ;;
    gnu* | linux* | kfreebsd*-gnu | knetbsd*-gnu)
@@ -14,7 +14,7 @@
      if [ "$uclibc" = "yes" ]; then
        os_include_dir="os/uclibc"
      elif [ "$bionic" = "yes" ]; then
-@@ -272,6 +279,9 @@ case "${host_os}" in
+@@ -271,6 +278,9 @@ case "${host_os}" in
        os_include_dir="os/gnu-linux"
      fi
      ;;
index 8a63fd1c75eaaa6543b8c2bf22bb77f9527719f2..3b6b42a0a9728873cf353da6c49fdd33e27f6d9a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/config/mips/linux.h
 +++ b/gcc/config/mips/linux.h
-@@ -29,4 +29,4 @@ along with GCC; see the file COPYING3.  
+@@ -29,4 +29,4 @@ along with GCC; see the file COPYING3.
  #else
  #define MUSL_DYNAMIC_LINKER_E "%{EL:el}"
  #endif
index 7447dbd307db69446bafc2a4b2c7db17c265c312..f10fc59d06219f0c9689068d330fb692ba5af451 100644 (file)
@@ -1,10 +1,8 @@
-Index: gcc-linaro-4.8-2014.04/gcc/config/mips/linux64.h
-===================================================================
---- gcc-linaro-4.8-2014.04.orig/gcc/config/mips/linux64.h      2014-10-23 15:52:48.999134219 -0700
-+++ gcc-linaro-4.8-2014.04/gcc/config/mips/linux64.h   2014-10-23 15:59:19.815116979 -0700
-@@ -27,6 +27,16 @@
- #define GLIBC_DYNAMIC_LINKERN32 "/lib32/ld.so.1"
- #define UCLIBC_DYNAMIC_LINKERN32 "/lib32/ld-uClibc.so.0"
+--- a/gcc/config/mips/linux64.h
++++ b/gcc/config/mips/linux64.h
+@@ -39,6 +39,16 @@ along with GCC; see the file COPYING3.
+   "%{mnan=2008:/lib32/ld-uClibc-mipsn8.so.0;:/lib32/ld-uClibc.so.0}"
  #define BIONIC_DYNAMIC_LINKERN32 "/system/bin/linker32"
 +
 +#if TARGET_ENDIAN_DEFAULT == 0 /* LE */
index 59022e3bade8860571dc1a3eaf856010f72260cd..0edeb13c7517ab16b7de8a7293a3a0f21bbb0ac5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/config/arm/arm.h
 +++ b/gcc/config/arm/arm.h
-@@ -282,7 +282,7 @@ extern void (*arm_lang_output_object_att
+@@ -285,7 +285,7 @@ extern void (*arm_lang_output_object_att
  /* Thumb-1 only.  */
  #define TARGET_THUMB1_ONLY            (TARGET_THUMB1 && !arm_arch_notm)
  
index 93bb3e826f269d867088c34739729bea83937e38..4e9b50c017d9bb41141381b607cb02abec8fd2dc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/config/rs6000/rs6000.c
 +++ b/gcc/config/rs6000/rs6000.c
-@@ -20853,7 +20853,7 @@ rs6000_savres_strategy (rs6000_stack_t *
+@@ -20869,7 +20869,7 @@ rs6000_savres_strategy (rs6000_stack_t *
    /* Define cutoff for using out-of-line functions to save registers.  */
    if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
      {
index f14f08587a1487d18ec42ff779b4268c738b4662..0f6998164125d3cc84962fbd057dc17dcdd99dea 100644 (file)
  ; On SVR4 targets, it also controls whether or not to emit a
 --- a/gcc/opts.c
 +++ b/gcc/opts.c
-@@ -1536,6 +1536,17 @@ common_handle_option (struct gcc_options
+@@ -1572,6 +1572,17 @@ common_handle_option (struct gcc_options
                               opts, opts_set, loc, dc);
        break;
  
  -Wfatal-errors  -Wfloat-equal  -Wformat  -Wformat=2 @gol
  -Wno-format-contains-nul -Wno-format-extra-args -Wformat-nonliteral @gol
  -Wformat-security  -Wformat-y2k @gol
-@@ -5042,6 +5042,22 @@ This option is only supported for C and 
+@@ -5042,6 +5042,22 @@ This option is only supported for C and
  @option{-Wall} and by @option{-Wpedantic}, which can be disabled with
  @option{-Wno-pointer-sign}.
  
  @item -Wstack-protector
  @opindex Wstack-protector
  @opindex Wno-stack-protector
-@@ -7189,7 +7205,7 @@ so, the first branch is redirected to ei
+@@ -7194,7 +7210,7 @@ so, the first branch is redirected to ei
  second branch or a point immediately following it, depending on whether
  the condition is known to be true or false.
  
index 1c0b34e630b7bb0472b5276f93dc35146d87f234..75379e494c51e7be99bb21f733805c051a1b286f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gcc/gcc.c
 +++ b/gcc/gcc.c
-@@ -8106,7 +8106,10 @@ getenv_spec_function (int argc, const ch
+@@ -8105,7 +8105,10 @@ getenv_spec_function (int argc, const ch
  
    value = getenv (argv[0]);
    if (!value)
index 72bacc1320832266abd9dd0556fc864c72be9442..8d94933ce9c220322a1f48f05a19d4d39321cfd5 100644 (file)
@@ -48,9 +48,9 @@ sellcey@mips.com
 
 --- a/gcc/config/mips/mips.c
 +++ b/gcc/config/mips/mips.c
-@@ -19134,6 +19134,9 @@ mips_atomic_assign_expand_fenv (tree *ho
- #undef TARGET_ATOMIC_ASSIGN_EXPAND_FENV
- #define TARGET_ATOMIC_ASSIGN_EXPAND_FENV mips_atomic_assign_expand_fenv
+@@ -19142,6 +19142,9 @@ mips_atomic_assign_expand_fenv (tree *ho
+ #define TARGET_USE_BY_PIECES_INFRASTRUCTURE_P \
+   mips_use_by_pieces_infrastructure_p
  
 +#undef TARGET_ASM_FILE_END
 +#define TARGET_ASM_FILE_END file_end_indicate_exec_stack
@@ -85,7 +85,7 @@ sellcey@mips.com
  
 --- a/libgcc/config/mips/mips16.S
 +++ b/libgcc/config/mips/mips16.S
-@@ -31,6 +31,10 @@ see the files COPYING3 and COPYING.RUNTI
+@@ -35,6 +35,10 @@ see the files COPYING3 and COPYING.RUNTI
     values using the soft-float calling convention, but do the actual
     operation using the hard floating point instructions.  */
  
index f87425581908c0b3e8b646a87a6be64e977f0205..32417942af625c44b0e03868fa5717a55a119d0d 100644 (file)
@@ -1,8 +1,6 @@
-Index: gcc-linaro-4.9-2014.10/libstdc++-v3/include/Makefile.in
-===================================================================
---- gcc-linaro-4.9-2014.10.orig/libstdc++-v3/include/Makefile.in       2013-11-16 12:44:48.000000000 -0500
-+++ gcc-linaro-4.9-2014.10/libstdc++-v3/include/Makefile.in    2014-12-02 06:23:02.236660279 -0500
-@@ -1366,7 +1366,7 @@
+--- a/libstdc++-v3/include/Makefile.in
++++ b/libstdc++-v3/include/Makefile.in
+@@ -1366,7 +1366,7 @@ stamp-bits: ${bits_headers}
        @$(STAMP) stamp-bits
  
  stamp-bits-sup: stamp-bits ${bits_sup_headers}