fstools: update to latest git HEAD
authorJohn Crispin <john@openwrt.org>
Mon, 7 Apr 2014 15:10:07 +0000 (15:10 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 7 Apr 2014 15:10:07 +0000 (15:10 +0000)
this adds the /sbin/ubi tool that can be used for sysupgrading ubi volumes

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 40415

package/system/fstools/Makefile
package/system/fstools/files/jffs2mark [deleted file]
package/system/fstools/files/jffs2reset [deleted file]
package/system/fstools/files/mount_root [deleted file]
package/system/fstools/files/snapshot

index f7e37bc919fa51363e12ed373410f1129d7fe05d..9672ee1da5dd63b30889d2c7e2247095d7d1260e 100644 (file)
@@ -1,14 +1,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fstools
-PKG_VERSION:=2014-04-01
+PKG_VERSION:=2014-04-07
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/fstools.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=4e3268f90ae97ccb047c47a78b83bcebeb9593cd
+PKG_SOURCE_VERSION:=a1f48fc0444f5c3c44ee6ef1005cd8da65decefd
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
@@ -29,6 +29,12 @@ define Package/fstools
   TITLE:=OpenWrt filesystem tools
 endef
 
+define Package/ubi-flash
+  SECTION:=base
+  CATEGORY:=Base system
+  TITLE:=OpenWrt ubi flashing tool
+endef
+
 define Package/block-mount
   SECTION:=base
   CATEGORY:=Base system
@@ -37,25 +43,34 @@ define Package/block-mount
 endef
 
 define Package/fstools/install
-       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_DIR) $(1)/sbin $(1)/lib
 
-       $(INSTALL_BIN) ./files/{jffs2reset,jffs2mark,mount_root} $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/fs-state $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,jffs2reset,snapshot_tool} $(1)/sbin/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libfstools.so $(1)/lib/
        $(INSTALL_BIN) ./files/snapshot $(1)/sbin/
+       ln -s /sbin/jffs2reset $(1)/sbin/jffs2mark
+endef
+
+define Package/ubi-flash/install
+       $(INSTALL_DIR) $(1)/sbin $(1)/lib
+
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ubi $(1)/sbin/
 endef
 
 define Package/block-mount/install
-       $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
+       $(INSTALL_DIR) $(1)/sbin $(1)/lib $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
 
        $(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
        $(INSTALL_DATA) ./files/fstab.default $(1)/etc/uci-defaults/10-fstab
        $(INSTALL_DATA) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
 
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libblkid-tiny.so $(1)/lib/
        ln -s /sbin/block $(1)/usr/sbin/swapon
        ln -s /sbin/block $(1)/usr/sbin/swapoff
 
 endef
 
 $(eval $(call BuildPackage,fstools))
+$(eval $(call BuildPackage,ubi-flash))
 $(eval $(call BuildPackage,block-mount))
diff --git a/package/system/fstools/files/jffs2mark b/package/system/fstools/files/jffs2mark
deleted file mode 100644 (file)
index 3f5a532..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-fs-state overlay jffs2mark $@
diff --git a/package/system/fstools/files/jffs2reset b/package/system/fstools/files/jffs2reset
deleted file mode 100644 (file)
index 9cdcc78..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-fs-state overlay jffs2reset $@
diff --git a/package/system/fstools/files/mount_root b/package/system/fstools/files/mount_root
deleted file mode 100644 (file)
index 860c194..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-fs-state start
index 85a0076d8e60d5743c54c410a8ac239b936b883d..1450e12458a54dd7e27d6199b0744f1f430748d6 100644 (file)
@@ -6,7 +6,7 @@ do_snapshot_unpack() {
        echo "- snapshot -"
        mkdir /tmp/snapshot
        cd /tmp/snapshot
-       fs-state snapshot read
+       snapshot_tool read
        block=`ls block*.tar.gz 2> /dev/null`
        [ -z "$block" ] || for a in $block; do
                tar xzf $a -C /
@@ -16,7 +16,7 @@ do_snapshot_unpack() {
 
 do_config_unpack() {
        echo "- config -"
-       fs-state snapshot config_read
+       snapshot_tool config_read
        [ -f /tmp/config.tar.gz ] && {
                tar xzf /tmp/config.tar.gz -C /
                rm -f /tmp/config.tar.gz
@@ -26,14 +26,14 @@ do_config_unpack() {
 do_snapshot_push() {
        cd /volatile
        tar czf /tmp/snapshot.tar.gz *
-       fs-state snapshot write
+       snapshot_tool write
        reboot
 }
 
 do_config_push() {
        cd /volatile
        tar czf /tmp/config.tar.gz *
-       fs-state snapshot config_write
+       snapshot_tool config_write
 }
 
 do_snapshot_upgrade() {
@@ -56,7 +56,7 @@ do_snapshot_upgrade() {
 }
 
 do_convert_jffs2() {
-       fs-state snapshot write
+       snapshot_tool write
        sleep 2
        reboot -f
 }
@@ -94,7 +94,7 @@ upgrade)
        do_snapshot_upgrade
        ;;
 info)
-       fs-state info
+       snapshot_tool info
        ;;
 esac
 }