remove unneeded patches
authorImre Kaloz <kaloz@openwrt.org>
Mon, 19 Jul 2010 11:28:20 +0000 (11:28 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 19 Jul 2010 11:28:20 +0000 (11:28 +0000)
SVN-Revision: 22287

target/linux/mx2/patches-2.6.34/020-fix-usb-ioresource.patch [deleted file]
target/linux/mx2/patches-2.6.34/030-lzma.patch [deleted file]

diff --git a/target/linux/mx2/patches-2.6.34/020-fix-usb-ioresource.patch b/target/linux/mx2/patches-2.6.34/020-fix-usb-ioresource.patch
deleted file mode 100644 (file)
index 004ca7a..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/arch/arm/mach-mx2/devices.c
-+++ b/arch/arm/mach-mx2/devices.c
-@@ -304,7 +304,7 @@ DEFINE_MXC_MMC_DEVICE(1, MX2x_SDHC2_BASE
- #ifdef CONFIG_MACH_MX27
- static struct resource otg_resources[] = {
-       {
--              .start = MX27_USBOTG_BASE_ADDR,
-+              .start = MX27_usbotg_BASE_ADDR,
-               .end = MX27_USBOTG_BASE_ADDR + 0x1ff,
-               .flags = IORESOURCE_MEM,
-       }, {
-@@ -483,8 +483,8 @@ int __init mxc_register_gpios(void)
- #ifdef CONFIG_MACH_MX21
- static struct resource mx21_usbhc_resources[] = {
-       {
--              .start  = MX21_BASE_ADDR,
--              .end    = MX21_BASE_ADDR + 0x1FFF,
-+              .start  = MX21_USBOTG_BASE_ADDR,
-+              .end    = MX21_USBOTG_BASE_ADDR + 0x1FFF,
-               .flags  = IORESOURCE_MEM,
-       },
-       {
diff --git a/target/linux/mx2/patches-2.6.34/030-lzma.patch b/target/linux/mx2/patches-2.6.34/030-lzma.patch
deleted file mode 100644 (file)
index 90a1e87..0000000
+++ /dev/null
@@ -1,61 +0,0 @@
-This patch allows using a kernel image compressed with LZMA on ARM.
-Extracting the image is fairly slow, but it might be useful on machines
-with a very limited amount of storage, as the size benefit is quite
-significant:
-Gzip: Data Size:    1586352 Bytes = 1549.17 kB = 1.51 MB
-LZMA: Data Size:    2135916 Bytes = 2085.86 kB = 2.04 MB
-
-Signed-off-by: Albin Tonnerre <albin.tonnerre <at> free-electrons.com>
-Tested-by: Martin Michlmayr <tbm <at> cyrius.com>
----
-v2: Updated to apply on top of 2.6.34-rc1
-
- arch/arm/Kconfig                      |    1 +
- arch/arm/boot/compressed/Makefile     |    1 +
- arch/arm/boot/compressed/decompress.c |    4 ++++
- arch/arm/boot/compressed/piggy.lzma.S |    6 ++++++
- 4 files changed, 12 insertions(+), 0 deletions(-)
- create mode 100644 arch/arm/boot/compressed/piggy.lzma.S
-
---- a/arch/arm/Kconfig
-+++ b/arch/arm/Kconfig
-@@ -21,6 +21,7 @@ config ARM
-       select HAVE_GENERIC_DMA_COHERENT
-       select HAVE_KERNEL_GZIP
-       select HAVE_KERNEL_LZO
-+      select HAVE_KERNEL_LZMA
-       select HAVE_PERF_EVENTS
-       select PERF_USE_VMALLOC
-       help
---- a/arch/arm/boot/compressed/Makefile
-+++ b/arch/arm/boot/compressed/Makefile
-@@ -65,6 +65,7 @@ SEDFLAGS     = s/TEXT_START/$(ZTEXTADDR)/;s/
- suffix_$(CONFIG_KERNEL_GZIP) = gzip
- suffix_$(CONFIG_KERNEL_LZO)  = lzo
-+suffix_$(CONFIG_KERNEL_LZMA) = lzma
- targets       := vmlinux vmlinux.lds \
-                piggy.$(suffix_y) piggy.$(suffix_y).o \
---- a/arch/arm/boot/compressed/decompress.c
-+++ b/arch/arm/boot/compressed/decompress.c
-@@ -40,6 +40,10 @@ extern void error(char *);
- #include "../../../../lib/decompress_unlzo.c"
- #endif
-+#ifdef CONFIG_KERNEL_LZMA
-+#include "../../../../lib/decompress_unlzma.c"
-+#endif
-+
- void do_decompress(u8 *input, int len, u8 *output, void (*error)(char *x))
- {
-       decompress(input, len, NULL, NULL, output, NULL, error);
---- /dev/null
-+++ b/arch/arm/boot/compressed/piggy.lzma.S
-@@ -0,0 +1,6 @@
-+      .section .piggydata,#alloc
-+      .globl  input_data
-+input_data:
-+      .incbin "arch/arm/boot/compressed/piggy.lzma"
-+      .globl  input_data_end
-+input_data_end: