only build gmp and mpfr when selecting gcc-4.3.x
authorFlorian Fainelli <florian@openwrt.org>
Wed, 21 Jan 2009 15:15:47 +0000 (15:15 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 21 Jan 2009 15:15:47 +0000 (15:15 +0000)
SVN-Revision: 14135

tools/Makefile

index 81c69b404f6a4af7bb29147872ac5d45c4ce669f..768f8786c6007910afa9750238d358a1ead97414 100644 (file)
@@ -9,7 +9,11 @@
 curdir:=tools
 
 # subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua quilt autoconf gmp mpfr
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) bison $(if $(CONFIG_powerpc),dtc) lua quilt autoconf
+
+ifeq ($(CONFIG_GCC_VERSION_4_3_1)$(CONFIG_GCC_VERSION_4_3_2),y)
+$(curdir)/builddirs += gmp mpfr
+endif
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install