add bc as required by kernels 3.9+
authorZoltan Herpai <wigyori@uid0.hu>
Mon, 8 Jul 2013 08:45:03 +0000 (08:45 +0000)
committerZoltan Herpai <wigyori@uid0.hu>
Mon, 8 Jul 2013 08:45:03 +0000 (08:45 +0000)
 - bc is required by the kernel to compute timeconsts files
 - fixes #13767.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
SVN-Revision: 37197

tools/Makefile
tools/bc/Makefile [new file with mode: 0644]

index 61b53a9a5517c25daadab41f7879008c7dbe87dd..a1e7c18bc26a6f93181ef41f7e0fd0ac16313ceb 100644 (file)
@@ -16,7 +16,7 @@ endif
 tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-image patch quilt yaffs2 flock padjffs2
 tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs e2fsprogs mtd-utils mkimage
 tools-y += firmware-utils patch-image patch quilt yaffs2 flock padjffs2
-tools-y += mm-macros xorg-macros xfce-macros missing-macros xz cmake scons
+tools-y += mm-macros xorg-macros xfce-macros missing-macros xz cmake scons bc
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_powerpc) += upx
 tools-$(CONFIG_TARGET_x86) += qemu
 tools-$(CONFIG_TARGET_orion_generic) += wrt350nv2-builder upslug2
 tools-$(CONFIG_powerpc) += upx
 tools-$(CONFIG_TARGET_x86) += qemu
diff --git a/tools/bc/Makefile b/tools/bc/Makefile
new file mode 100644 (file)
index 0000000..87c7e58
--- /dev/null
@@ -0,0 +1,18 @@
+# 
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bc
+PKG_VERSION:=1.06.95
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://alpha.gnu.org/gnu/bc
+PKG_MD5SUM:=5126a721b73f97d715bb72c13c889035
+
+include $(INCLUDE_DIR)/host-build.mk
+
+$(eval $(call HostBuild))