Updated acx (#2394) and fixed acx-mac80211 build
authorMatteo Croce <rootkit85@yahoo.it>
Sun, 16 Sep 2007 15:13:50 +0000 (15:13 +0000)
committerMatteo Croce <rootkit85@yahoo.it>
Sun, 16 Sep 2007 15:13:50 +0000 (15:13 +0000)
SVN-Revision: 8797

package/acx-mac80211/Makefile
package/acx/Makefile
package/acx/patches/003-2.6.22_compat.patch [deleted file]

index 5578d645ef51862fe1770a81213dd89bdf0eeec0..f6e85511321abc39b7522b290195a2176df651bc 100644 (file)
@@ -31,7 +31,6 @@ define KernelPackage/acx-mac80211
   TITLE:=ACX111 Mac80211 driver
   DESCRIPTION:=Driver for acx111 cards (Mac80211 version)
   DEPENDS:=@LINUX_2_6 +kmod-mac80211
-  KCONFIG:=CONFIG_MAC80211
   FILES:=$(PKG_BUILD_DIR)/acx-mac80211.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,acx-mac80211)
 endef
index 77ec91b121d640dbdc126498a4b58be43b9680f9..a0e087aec597638255929c98b75a297adea55188 100644 (file)
@@ -10,12 +10,16 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=acx
-PKG_VERSION:=20070101
+PKG_VERSION:=20070610
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@openwrt/
-PKG_MD5SUM:=ec6322b9c82781897a9433ef0cefda6f
+PKG_MD5SUM:=ce36d3d00f87a331d3dee6d5359d4499
+
+PKG_FW_NAME:=tiacx111c16
+PKG_FW_URL:=http://teknoraver.campuslife.it/software/acx-mac80211/
+PKG_FW_MD5SUM:=7026826460376f6b174f9225bd7781b9
 
 PKG_UNPACK:= \
        bzcat $(DL_DIR)/$(PKG_SOURCE) | \
@@ -37,6 +41,12 @@ define KernelPackage/acx/description
  This package contains a driver for TI ACX1xx 802.11a/b/g chipsets.
 endef
 
+$(STAMP_BUILT): $(DL_DIR)/$(PKG_FW_NAME)
+
+$(DL_DIR)/$(PKG_FW_NAME):
+       $(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_FW_NAME)" "$(PKG_FW_MD5SUM)" $(PKG_FW_URL)
+
+
 define Build/Compile
        $(MAKE) -C $(LINUX_DIR) \
                SUBDIRS="$(PKG_BUILD_DIR)" \
@@ -53,4 +63,9 @@ define Build/Compile
                modules
 endef
 
+define KernelPackage/acx/install
+       $(INSTALL_DIR) $(1)/lib/firmware
+       $(INSTALL_DATA) $(DL_DIR)/$(PKG_FW_NAME) $(1)/lib/firmware/
+endef
+
 $(eval $(call KernelPackage,acx))
diff --git a/package/acx/patches/003-2.6.22_compat.patch b/package/acx/patches/003-2.6.22_compat.patch
deleted file mode 100644 (file)
index 8f8f9ad..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur acx-20070101/common.c acx-20070101-owrt/common.c
---- acx-20070101/common.c      2007-01-10 22:15:27.000000000 +0100
-+++ acx-20070101-owrt/common.c 2007-06-02 18:02:39.000000000 +0200
-@@ -2754,7 +2754,7 @@
-       skb->dev = adev->ndev;
-       skb->dev->last_rx = jiffies;
--      skb->mac.raw = skb->data;
-+//    skb->mac.raw = skb->data;
-       skb->ip_summed = CHECKSUM_NONE;
-       skb->pkt_type = PACKET_OTHERHOST;
-       skb->protocol = htons(ETH_P_80211_RAW);