build: remove profile kernel/build system config override support
authorFelix Fietkau <nbd@nbd.name>
Sun, 15 May 2016 18:35:58 +0000 (20:35 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sun, 15 May 2016 18:55:40 +0000 (20:55 +0200)
It has been unused for years

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/target.mk
scripts/metadata.pl
scripts/metadata.pm
target/Config.in
target/imagebuilder/Config.in

index 0666df63a157f3d8d3f08b60836e90a360b4ee4e..92edaec96b0e8b40a4cdcc3bee02912c30232ff9 100644 (file)
@@ -67,19 +67,12 @@ ifndef Profile
 define Profile
   $(eval $(call ProfileDefault))
   $(eval $(call Profile/$(1)))
-  dumpinfo : $(call shexport,Profile/$(1)/Config)
   dumpinfo : $(call shexport,Profile/$(1)/Description)
   DUMPINFO += \
        echo "Target-Profile: $(1)"; \
        $(if $(PRIORITY), echo "Target-Profile-Priority: $(PRIORITY)"; ) \
        echo "Target-Profile-Name: $(NAME)"; \
        echo "Target-Profile-Packages: $(PACKAGES) $(call extra_packages,$(DEFAULT_PACKAGES) $(PACKAGES))"; \
-       if [ -f ./config/profile-$(1) ]; then \
-               echo "Target-Profile-Kconfig: yes"; \
-       fi; \
-       echo "Target-Profile-Config: "; \
-       echo "$$$$$$$$$(call shvar,Profile/$(1)/Config)"; \
-       echo "@@"; \
        echo "Target-Profile-Description:"; \
        echo "$$$$$$$$$(call shvar,Profile/$(1)/Description)"; \
        echo "@@"; \
index c7582b42dc5b2a3901667476229fe7744c680cea..822382cd6c865ec2a0407d89f000e867819266e2 100755 (executable)
@@ -287,9 +287,7 @@ EOF
 config TARGET_$target->{conf}_$profile->{id}
        bool "$profile->{name}"
        depends on TARGET_$target->{conf}
-$profile->{config}
 EOF
-                       $profile->{kconfig} and print "\tselect PROFILE_KCONFIG\n";
                        my @pkglist = merge_package_lists($target->{packages}, $profile->{packages});
                        foreach my $pkg (@pkglist) {
                                print "\tselect DEFAULT_$pkg\n";
index e2a739533cc963dc4eeab86e83ffb3313b0c8b9d..b3f34f79e9fef9300ed5783b25923b64525a9a5c 100644 (file)
@@ -96,8 +96,6 @@ sub parse_target_metadata($) {
                };
                /^Target-Profile-Packages:\s*(.*)\s*$/ and $profile->{packages} = [ split(/\s+/, $1) ];
                /^Target-Profile-Description:\s*(.*)\s*/ and $profile->{desc} = get_multiline(*FILE);
-               /^Target-Profile-Config:/ and $profile->{config} = get_multiline(*FILE, "\t");
-               /^Target-Profile-Kconfig:/ and $profile->{kconfig} = 1;
        }
        close FILE;
        foreach my $target (@target) {
index 571b06ebcff672106c26ee8b2e201649951325d0..3dc8655252af723067ecf6aabf51919499293e13 100644 (file)
@@ -67,9 +67,6 @@ config USES_UBIFS
        bool
        select NAND_SUPPORT
 
-config PROFILE_KCONFIG
-       bool
-
 config LOW_MEMORY_FOOTPRINT
        bool
 
index 245c71583df9d250c63605563afc04701b056315..b54eb5b4ffc6546d19cf53b4aed5d2ea85c6f5e5 100644 (file)
@@ -1,6 +1,5 @@
 config IB
        bool "Build the LEDE Image Builder"
-       depends on !PROFILE_KCONFIG
        depends on !EXTERNAL_TOOLCHAIN
        help
          This is essentially a stripped-down version of the buildroot