cleanup
authorFelix Fietkau <nbd@openwrt.org>
Sat, 14 Oct 2006 22:11:21 +0000 (22:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 14 Oct 2006 22:11:21 +0000 (22:11 +0000)
SVN-Revision: 5097

tools/sstrip/Makefile
tools/sstrip/src/sstrip.c

index 4e409e0d8dc598d270a1d80de7971a44e6e919fc..87f331214ad138d72f850d4a347fd815caafd7ca 100644 (file)
@@ -13,6 +13,7 @@ OS:=$(shell uname)
 ifeq ($(HOST_OS),Darwin)
   CFLAGS += -I./include
 endif
+CFLAGS += -I $(TOPDIR)/tools/include -include endian.h
 
 define Build/Compile
        $(CC) $(CFLAGS) -o $(PKG_BUILD_DIR)/sstrip src/sstrip.c
index 60c12c972c8ef2979beaac73486ce4d23ff763c0..6607d12500547787e4eacc230b1be4db2dfd823d 100644 (file)
 #include       <fcntl.h>
 #include       <elf.h>
 
-#ifdef __FreeBSD__
-/**
- * This seems to work on FreeBSD 5.3, should
- * work on all newer versions as well. I have
- * no idea if it will work on versions < 5.3
- *
- * Joe Estock (guru) <jestock at nutextonline.com>
- */
-#include <sys/endian.h>
-#define bswap_64 __bswap64
-#define bswap_32 __bswap32
-#define bswap_16 __bswap16
-#elif defined(__APPLE__)
-#include       <machine/endian.h>
-#include       <machine/byte_order.h>
-#define __BYTE_ORDER BYTE_ORDER
-#define __BIG_ENDIAN BIG_ENDIAN
-#define bswap_16(x) NXSwapShort(x)
-#define bswap_32(x) NXSwapInt(x)
-#define bswap_64(x) NXSwapLongLong(x)
-#else
-#include       <endian.h>
-#include       <byteswap.h>
-#endif 
-
-
 #ifndef TRUE
 #define        TRUE            1
 #define        FALSE           0