update acx-mac80211
authorMatteo Croce <rootkit85@yahoo.it>
Sun, 23 Sep 2007 21:07:53 +0000 (21:07 +0000)
committerMatteo Croce <rootkit85@yahoo.it>
Sun, 23 Sep 2007 21:07:53 +0000 (21:07 +0000)
SVN-Revision: 9001

package/acx-mac80211/Makefile
package/acx-mac80211/patches/003-endianness_fixes.patch
package/acx-mac80211/patches/011-no_pm.patch

index 5578d645ef51862fe1770a81213dd89bdf0eeec0..7bc37ee84cf02def12f55363bfce106876ad2204 100644 (file)
@@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=acx-mac80211
-PKG_VERSION:=20070610
+PKG_VERSION:=20070718
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.hauke-m.de/fileadmin/acx
-PKG_MD5SUM:=7c6c70722a5a2ad6ad25075467ea4909
+PKG_SOURCE_URL:=http://teknoraver.campuslife.it/software/acx-mac80211/
+PKG_MD5SUM:=c6f339384c8ad17181a9f867a227ddae
 
 PKG_FW_NAME:=tiacx111c16
 PKG_FW_URL:=http://teknoraver.campuslife.it/software/acx-mac80211/
@@ -31,7 +31,7 @@ define KernelPackage/acx-mac80211
   TITLE:=ACX111 Mac80211 driver
   DESCRIPTION:=Driver for acx111 cards (Mac80211 version)
   DEPENDS:=@LINUX_2_6 +kmod-mac80211
-  KCONFIG:=CONFIG_MAC80211
+# KCONFIG:=CONFIG_MAC80211
   FILES:=$(PKG_BUILD_DIR)/acx-mac80211.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,acx-mac80211)
 endef
index f1d8da5b484b1ad8bb7c9a93a069851fdcf17b5f..5ced16479953153f33181275cd86f5b6ab06e8e9 100644 (file)
            "waiting for cards to probe...\n");
  
        res = pci_register_driver(&acxpci_drv_id);
-diff -ruN acx-mac80211-20070610-old/wlan_hdr.h acx-mac80211-20070610-new/wlan_hdr.h
---- acx-mac80211-20070610-old/wlan_hdr.h       2007-06-10 20:23:27.000000000 +0200
-+++ acx-mac80211-20070610-new/wlan_hdr.h       2007-08-30 18:56:23.000000000 +0200
-@@ -125,7 +125,7 @@
-  #define IEEE16(a,n) a = n, a##i = n,
- #else
-  #ifdef __BIG_ENDIAN
--  #define IEEE16(a,n) a = n a##i = ((n&0xff)*256 + ((n&0xff00/256)),
-+  #define IEEE16(a,n) a = n, a##i = ((n&0xff)*256 + (n&0xff00)/256),
-  #endif
- #endif
index 09a00b04e5e3ed7ad7f3b81b18899985afc15446..a78e453a894c1c97510f46b04b4a9c00a473d04a 100644 (file)
        fail_register_netdev:
        ieee80211_free_hw(ieee);
        done:
-@@ -1872,7 +1876,9 @@
+@@ -1809,7 +1821,9 @@
        ieee80211_free_hw(adev->ieee);
  
        /* put device into ACPI D3 mode (shutdown) */
 +#ifdef CONFIG_PM
        pci_set_power_state(pdev, PCI_D3hot);
 +#endif
- //    kfree(ieee);
        end:
        FN_EXIT0;
+ }
\ No newline at end of file