busybox: remove the -static-libgcc flag, saves a few kb
authorFelix Fietkau <nbd@openwrt.org>
Tue, 1 Mar 2011 05:40:57 +0000 (05:40 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 1 Mar 2011 05:40:57 +0000 (05:40 +0000)
SVN-Revision: 25802

package/busybox/patches/150-no_static_libgcc.patch [new file with mode: 0644]

diff --git a/package/busybox/patches/150-no_static_libgcc.patch b/package/busybox/patches/150-no_static_libgcc.patch
new file mode 100644 (file)
index 0000000..fde6fbb
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile.flags
++++ b/Makefile.flags
+@@ -50,7 +50,7 @@ CFLAGS += $(call cc-option,-fno-builtin-
+ # -fno-guess-branch-probability: prohibit pseudo-random guessing
+ # of branch probabilities (hopefully makes bloatcheck more stable):
+ CFLAGS += $(call cc-option,-fno-guess-branch-probability,)
+-CFLAGS += $(call cc-option,-funsigned-char -static-libgcc,)
++CFLAGS += $(call cc-option,-funsigned-char,)
+ CFLAGS += $(call cc-option,-falign-functions=1 -falign-jumps=1 -falign-labels=1 -falign-loops=1,)
+ # FIXME: These warnings are at least partially to be concerned about and should