ramips: add support for MikroTik hEX v3 (RB750Gr3)
authorAndrew Yong <me@ndoo.sg>
Tue, 18 Oct 2016 20:05:32 +0000 (04:05 +0800)
committerJohn Crispin <john@phrozen.org>
Wed, 2 Nov 2016 09:25:44 +0000 (10:25 +0100)
The MikroTik hEX v3 (RB750Gr3) is a MT7621AT board which is similar to most MT7621 reference designs, it can be easily supported by this patch; however, the stock RouterBOOT bootloader has to be replaced by a MT7621 SDK U-Boot such as https://github.com/ndoo/RB750Gr3-U-Boot - U-Boot configured for the RB750Gr3 (16MiB SPI flash, 256MiB DDR3 RAM at 1200MHz).

RouterBOOT, the stock bootloader, does not initialize the UART and boots silently, making it preferable to replace it with a MT7621 SDK U-Boot with UART (57600 8N1) that supports HTTP, TFTP or serial upload of sysupgrade firmware and U-Boot.

Furthermore, RouterOS, the stock firmware, is contained in a proprietary modification of SquashFS without GPL sources; UART is also disabled in stock firmware.

The combination of LEDE firmware generated by this PR and MT7621 SDK U-Boot expects the printed MAC address to reside at offset `0xe000` of the factory partition (absolute offset is `0x4e000`); this is similar to the factory MAC address offset for several other MT7621 devices.

A 16MiB flash dump suitable for use with flashrom will be provided if/once this patch is accepted and binaries are built by LEDE buildbot. Alternatively, writing the U-Boot to the SPI flash starting at 0x0 offset and booting the board with serial console attached will allow TFTP, HTTP or serial upload of sysupgrade firmware.

Signed-off-by: Andrew Yong <me@ndoo.sg>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/RB750Gr3.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk

index 99c90e4590b55b457a5e92787c8ba964eacbfe0f..ece48c08e0cf733de614374a20cc5bcc073711bf 100755 (executable)
@@ -134,6 +134,7 @@ ramips_setup_interfaces()
        jhr-n825r|\
        jhr-n926r|\
        mzk-wdpr|\
+       rb750gr3|\
        rt-n14u|\
        ubnt-erx|\
        ur-326n4g|\
index ff8f4c5118947429c2f90bd4f6f9ffc0847c6e11..a229bbb1a39bfa56212ef4d633997746caca69e0 100644 (file)
@@ -188,6 +188,9 @@ get_status_led() {
        wr512-3gn)
                status_led="$board:green:wps"
                ;;
+       rb750gr3)
+               status_led="$board:green:usr"
+               ;;
        sap-g3200u3)
                status_led="$board:green:usb"
                ;;
index 526a5ae669794c85a5782a2a846b937decb60f4f..50bdffc5fa951701a183f181a365ca16904c3b60 100755 (executable)
@@ -367,6 +367,9 @@ ramips_board_detect() {
        *"Q7")
                name="zte-q7"
                ;;
+       *"RB750Gr3")
+               name="rb750gr3"
+               ;;
        *"RE6500")
                name="re6500"
                ;;
index 9c49c8070d9d38346e3d5fbef3803b9f089e2d27..da496e8ab523a4571300b8a872fd9b1d2f7d49e4 100755 (executable)
@@ -105,6 +105,7 @@ platform_check_image() {
        psg1218|\
        psr-680w|\
        px-4885|\
+       rb750gr3|\
        re6500|\
        rp-n53|\
        rt5350f-olinuxino|\
diff --git a/target/linux/ramips/dts/RB750Gr3.dts b/target/linux/ramips/dts/RB750Gr3.dts
new file mode 100644 (file)
index 0000000..d39a2d1
--- /dev/null
@@ -0,0 +1,121 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+
+/ {
+       compatible = "mediatek,mt7621-eval-board", "mediatek,mt7621-soc";
+       model = "MikroTik RB750Gr3";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x10000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               usr {
+                       label = "rb750gr3:green:usr";
+                       gpios = <&gpio0 0 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               mode {
+                       label = "mode";
+                       gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RFKILL>;
+               };
+
+               res {
+                       label = "res";
+                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+
+       gpio_export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               usb {
+                       gpio-export,name = "usb";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio0 12 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               linux,modalias = "m25p80";
+               spi-max-frequency = <10000000>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0xfb0000>;
+               };
+
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0xe000>;
+       mtd-mac-address-increment = <1>;
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "i2c", "rgmii2", "sdhci";
+                       ralink,function = "gpio";
+               };
+       };
+};
+
+&sdhci {
+       status = "okay";
+};
+
+&xhci {
+       status = "okay";
+};
+
+&pcie {
+       status = "disabled";
+};
index 59744087905e4b03f27e5ec3593ddae6ea5d7777..10ab82a82d98e5f27451f1ded949dab4deb1879b 100644 (file)
@@ -191,6 +191,14 @@ define Device/vr500
 endef
 TARGET_DEVICES += vr500
 
+define Device/rb750gr3
+  DTS := RB750Gr3
+  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+  DEVICE_TITLE := MikroTik RB750Gr3
+  DEVICE_PACKAGES := kmod-usb3 kmod-ledtrig-usbdev uboot-envtools -kmod-mt76 -kmod-rt2x00-lib -kmod-mac80211 -kmod-cfg80211 -wpad-mini -iwinfo
+endef
+TARGET_DEVICES += rb750gr3
+
 # FIXME: is this still needed?
 define Image/Prepare
 #define Build/Compile