Update default configuration to use profiles
authorHamish Guthrie <hcg@openwrt.org>
Thu, 16 Apr 2009 10:40:15 +0000 (10:40 +0000)
committerHamish Guthrie <hcg@openwrt.org>
Thu, 16 Apr 2009 10:40:15 +0000 (10:40 +0000)
SVN-Revision: 15229

include/target.mk
target/linux/ps3/Makefile
target/linux/ps3/config-2.6.28
target/linux/ps3/petitboot/base-files/etc/config/network [new file with mode: 0644]
target/linux/ps3/petitboot/base-files/etc/init.d/boot
target/linux/ps3/petitboot/base-files/etc/sysctl.conf [new file with mode: 0644]
target/linux/ps3/petitboot/profiles/000-Default.mk [new file with mode: 0644]
target/linux/ps3/petitboot/target.mk

index baca4b5e792e66ee4971ae8fac4e6aef88c1b1fa..2f62c2a8cd72faa2a1b5bf045e8c9d994c44a239 100644 (file)
@@ -15,7 +15,7 @@ DEVICE_TYPE?=router
 DEFAULT_PACKAGES:=base-files libc libgcc busybox dropbear mtd uci opkg
 # For router targets
 DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe kmod-ipt-nathelper firewall
-DEFAULT_PACKAGES.bootloader:=kexec-tools
+DEFAULT_PACKAGES.bootloader:=
 
 # Additional packages for Linux 2.6
 ifneq ($(KERNEL),2.4)
index b28dba361633203cdb73df48928979ad087472d6..40f8059eafd25c9f8c6e1f94a6873f01a4914a0a 100644 (file)
@@ -12,8 +12,6 @@ BOARDNAME:=Sony PS3 Game Console
 MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
 SUBTARGETS=petitboot
 
-DEVICE_TYPE=bootloader
-
 LINUX_VERSION:=2.6.28.9
 
 KERNEL_CC:=
index 4ad7dadd7fe67a05d56827bab83f9b0b532f26e4..f61e0df82a85871021b14e0d0864d16c1e3a898d 100644 (file)
@@ -169,9 +169,12 @@ CONFIG_INITRAMFS_SOURCE="/home/geoff/projects/cell/bootloader/openwrt-feeds/buil
 CONFIG_INOTIFY=y
 CONFIG_INOTIFY_USER=y
 CONFIG_INPUT=y
+CONFIG_INPUT_EVBUG=m
+CONFIG_INPUT_EVDEV=m
+CONFIG_INPUT_JOYDEV=m
 CONFIG_INPUT_JOYSTICK=y
 CONFIG_INPUT_MOUSEDEV=y
-# CONFIG_INPUT_MOUSEDEV_PSAUX is not set
+CONFIG_INPUT_MOUSEDEV_PSAUX=y
 CONFIG_INPUT_MOUSEDEV_SCREEN_X=1024
 CONFIG_INPUT_MOUSEDEV_SCREEN_Y=768
 CONFIG_IOMMU_HELPER=y
@@ -337,7 +340,8 @@ CONFIG_SUNRPC=y
 CONFIG_SUNRPC_GSS=y
 # CONFIG_SYN_COOKIES is not set
 # CONFIG_SYSCTL_SYSCALL_CHECK is not set
-# CONFIG_SYSVIPC is not set
+CONFIG_SYSVIPC_COMPAT=y
+CONFIG_SYSVIPC_SYSCTL=y
 # CONFIG_TCP_CONG_ADVANCED is not set
 CONFIG_TCP_CONG_CUBIC=y
 CONFIG_TINY_SHMEM=y
diff --git a/target/linux/ps3/petitboot/base-files/etc/config/network b/target/linux/ps3/petitboot/base-files/etc/config/network
new file mode 100644 (file)
index 0000000..453481e
--- /dev/null
@@ -0,0 +1,13 @@
+# Copyright (C) 2006 OpenWrt.org
+
+config interface loopback
+       option ifname   lo
+       option proto    static
+       option ipaddr   127.0.0.1
+       option netmask  255.0.0.0
+
+config interface lan
+       option ifname   eth0
+       option proto    dhcp
+       option ipaddr   192.168.1.1
+       option netmask  255.255.255.0
index 2897f3a7da3151621777761510b95f1a79372a9f..c84c6873d329588e6b3694f67990be14dd0cb9f2 100755 (executable)
@@ -19,12 +19,13 @@ system_config() {
 
        config_get log_ip "$cfg" log_ip
        config_get log_size "$cfg" log_size
+       config_get log_port "$cfg" log_port
        config_get log_file "$cfg" log_file
-       # use a shared mem buffer for local default
+
        [ -z $log_file -a -z "$log_size" ] && log_size=16
-       syslogd ${log_size:+-C $log_size} ${log_file:+-O $log_file} \
-               ${log_ip:+-L -R $log_ip}
-       klogd
+       [ -x /sbin/syslogd ] && syslogd ${log_size:+-C $log_size} \
+               ${log_file:+-O $log_file} ${log_ip:+-L -R $log_ip}
+       [ -x /sbin/klogd ] && klogd
 }
 
 apply_uci_config() {(
@@ -37,16 +38,15 @@ start() {
        [ -f /proc/jffs2_bbc ] && echo "S" > /proc/jffs2_bbc
        [ -f /proc/net/vlan/config ] && vconfig set_name_type DEV_PLUS_VID_NO_PAD
 
+       apply_uci_config
+       config_load system
+       config_foreach system_config system
+
        mkdir -p /var/run
        mkdir -p /var/log
        mkdir -p /var/lock
        mkdir -p /var/state
        mkdir -p /tmp/.uci
-
-       apply_uci_config
-       config_load system
-       config_foreach system_config system
-
        chown 0700 /tmp/.uci
        touch /var/log/wtmp
        touch /var/log/lastlog
diff --git a/target/linux/ps3/petitboot/base-files/etc/sysctl.conf b/target/linux/ps3/petitboot/base-files/etc/sysctl.conf
new file mode 100644 (file)
index 0000000..1af0079
--- /dev/null
@@ -0,0 +1,11 @@
+kernel.panic=3
+net.ipv4.conf.default.arp_ignore=1
+net.ipv4.conf.all.arp_ignore=1
+net.ipv4.ip_forward=1
+net.ipv4.icmp_echo_ignore_broadcasts=1
+net.ipv4.icmp_ignore_bogus_error_responses=1
+net.ipv4.tcp_ecn=1 
+net.ipv4.tcp_fin_timeout=30
+net.ipv4.tcp_keepalive_time=120
+net.ipv4.tcp_timestamps=0
+net.core.netdev_max_backlog=30
diff --git a/target/linux/ps3/petitboot/profiles/000-Default.mk b/target/linux/ps3/petitboot/profiles/000-Default.mk
new file mode 100644 (file)
index 0000000..5c433e1
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+  NAME:=Default PS3 Petitboot profile
+  PACKAGES:=-dnsmasq -iptables -ppp -ppp-mod-pppoe -kmod-ipt-nathelper \
+           -firewall \
+           kexec-tools petitboot
+endef
+
+define Profile/Default/Description
+        Default PS3 Petitboot profile
+endef
+$(eval $(call Profile,Default))
+
index 4b53f57b6b3bb6fcbf28279a766dea2227512aeb..04ec11bb3e2d1a54b27765e34b49bf3d3870d471 100644 (file)
@@ -1,8 +1,6 @@
 BOARDNAME:=Petitboot
 FEATURES:=fpu ramdisk
 
-DEFAULT_PACKAGES+= dnsmasq petitboot
-
 define Target/Description
        Build Petitboot bootloader
 endef