add a flag "IGNORE_ERRORS", which can be used to ignore build errors in packages
[openwrt/svn-archive/archive.git] / include / kernel-version.mk
1 # Use the default kernel version if the Makefile doesn't override it
2
3 ifeq ($(KERNEL),2.4)
4 LINUX_VERSION?=2.4.35.4
5 else
6 LINUX_VERSION?=2.6.21.5
7 endif
8 LINUX_RELEASE?=1
9
10 ifeq ($(LINUX_VERSION),2.4.34)
11 LINUX_KERNEL_MD5SUM:=f59665540a7f3351ea416a0dad104b55
12 endif
13 ifeq ($(LINUX_VERSION),2.4.35.4)
14 LINUX_KERNEL_MD5SUM:=34066faff3d8c042df1c7600b08b8070
15 endif
16 ifeq ($(LINUX_VERSION),2.6.21.7)
17 LINUX_KERNEL_MD5SUM:=bc15fad1487336d5dcb0945cd039d8ed
18 endif
19 ifeq ($(LINUX_VERSION),2.6.22.18)
20 LINUX_KERNEL_MD5SUM:=bd375d5885bf114c74a2216d52d86e34
21 endif
22 ifeq ($(LINUX_VERSION),2.6.23.16)
23 LINUX_KERNEL_MD5SUM:=2637a7f1d4450bc5e27422f307fc6529
24 endif
25 ifeq ($(LINUX_VERSION),2.6.24.5)
26 LINUX_KERNEL_MD5SUM:=26500f8f92895bd33e391088b5edd4ad
27 endif
28 ifeq ($(LINUX_VERSION),2.6.25.1)
29 LINUX_KERNEL_MD5SUM:=0d26fcafa00dc5cf27d4bf01301409a0
30 endif
31
32 # disable the md5sum check for unknown kernel versions
33 LINUX_KERNEL_MD5SUM?=x
34
35 KERNEL?=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
36 KERNEL_PATCHVER=$(shell echo '$(LINUX_VERSION)' | cut -d. -f1,2,3 | cut -d- -f1)
37