[package] gettext-full: fix build on eglibc
[openwrt/svn-archive/archive.git] / libs / gettext-full / patches / 160-eglibc_stdio.patch
1 --- a/gettext-runtime/gnulib-lib/stdio.in.h
2 +++ b/gettext-runtime/gnulib-lib/stdio.in.h
3 @@ -141,7 +141,9 @@ _GL_WARN_ON_USE (fflush, "fflush is not
4 so any use of gets warrants an unconditional warning. Assume it is
5 always declared, since it is required by C89. */
6 #undef gets
7 +#if HAVE_RAW_DECL_GETS
8 _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
9 +#endif
10
11 #if @GNULIB_FOPEN@
12 # if @REPLACE_FOPEN@
13 --- a/gettext-tools/gnulib-lib/stdio.in.h
14 +++ b/gettext-tools/gnulib-lib/stdio.in.h
15 @@ -141,7 +141,9 @@ _GL_WARN_ON_USE (fflush, "fflush is not
16 so any use of gets warrants an unconditional warning. Assume it is
17 always declared, since it is required by C89. */
18 #undef gets
19 +#if HAVE_RAW_DECL_GETS
20 _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
21 +#endif
22
23 #if @GNULIB_FOPEN@
24 # if @REPLACE_FOPEN@
25 --- a/gettext-tools/libgettextpo/stdio.in.h
26 +++ b/gettext-tools/libgettextpo/stdio.in.h
27 @@ -141,7 +141,9 @@ _GL_WARN_ON_USE (fflush, "fflush is not
28 so any use of gets warrants an unconditional warning. Assume it is
29 always declared, since it is required by C89. */
30 #undef gets
31 +#if HAVE_RAW_DECL_GETS
32 _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
33 +#endif
34
35 #if @GNULIB_FOPEN@
36 # if @REPLACE_FOPEN@