fix howl build on 2.4 after [6004]: <linux/ethtool.h> uses u* types on 2.4 and __u...
[openwrt/svn-archive/archive.git] / libs / howl / patches / 04-linux_types.patch
1 diff -ruN howl-1.0.0-old/src/lib/howl/Posix/posix_interface.c howl-1.0.0-new/src/lib/howl/Posix/posix_interface.c
2 --- howl-1.0.0-old/src/lib/howl/Posix/posix_interface.c 2005-05-19 23:39:27.000000000 +0200
3 +++ howl-1.0.0-new/src/lib/howl/Posix/posix_interface.c 2007-01-07 23:56:54.000000000 +0100
4 @@ -41,6 +41,7 @@
5 typedef __uint32_t u32;
6 typedef __uint16_t u16;
7 typedef __uint8_t u8;
8 +# include <linux/types.h>
9 # include <linux/sockios.h>
10 # include <linux/ethtool.h>
11 #endif