gspcav1 cannot be compiled under 2.6.27/2.6.28 at the moment, mask it
[openwrt/svn-archive/archive.git] / multimedia / gspcav1 / Makefile
1 #
2 # Copyright (C) 2006 OpenWrt.org
3 #
4 # This is free software, licensed under the GNU General Public License v2.
5 # See /LICENSE for more information.
6 #
7 # $Id$
8
9 include $(TOPDIR)/rules.mk
10 include $(INCLUDE_DIR)/kernel.mk
11
12 PKG_NAME:=gspcav1
13 PKG_VERSION:=20071224
14 PKG_RELEASE:=1
15
16 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
17 PKG_SOURCE_URL:=http://mxhaard.free.fr/spca50x/Download
18 PKG_MD5SUM:=14853ba1f4edc1e685039fca56e5ebf
19
20 include $(INCLUDE_DIR)/package.mk
21
22 define KernelPackage/video-gspca
23 SUBMENU:=Video Support
24 TITLE:=SPCA5xx based USB webcam support
25 URL:=http://mxhaard.free.fr/
26 DEPENDS:=@LINUX_2_6 @!LINUX_2_6_27 @!LINUX_2_6_28 @USB_SUPPORT @!TARGET_uml +kmod-usb-core +kmod-video-core
27 FILES:=$(PKG_BUILD_DIR)/gspca.$(LINUX_KMOD_SUFFIX)
28 AUTOLOAD:=$(call AutoLoad,90,gspca)
29 endef
30
31 define Build/Compile
32 $(MAKE) -C $(LINUX_DIR) \
33 ARCH="$(LINUX_KARCH)" \
34 CROSS_COMPILE="$(TARGET_CROSS)" \
35 SUBDIRS="$(PKG_BUILD_DIR)" \
36 modules
37 endef
38
39 $(eval $(call KernelPackage,video-gspca))