[packages] nzbget: fix compilation against OpenSSL v1.x (#8893)
[openwrt/svn-archive/archive.git] / net / asterisk-1.4.x / patches / 014-openssl-configure_ac.patch
1 --- a/configure.ac
2 +++ b/configure.ac
3 @@ -1376,7 +1376,7 @@ AC_SUBST(PBX_SPEEX_PREPROCESS)
4
5 AST_EXT_LIB_CHECK([SQLITE], [sqlite], [sqlite_exec], [sqlite.h])
6
7 -AST_EXT_LIB_CHECK([OPENSSL], [ssl], [ssl2_connect], [openssl/ssl.h], [-lcrypto])
8 +AST_EXT_LIB_CHECK([OPENSSL], [ssl], [ssl23_connect], [openssl/ssl.h], [-lcrypto])
9 if test "$PBX_OPENSSL" = "1";
10 then
11 AST_EXT_LIB_CHECK([OSPTK], [osptk], [OSPPCryptoDecrypt], [osp/osp.h], [-lcrypto -lssl])