[package] update gpsd to 2.94, add config, init and hotplug scripts, patch from Rober...
[openwrt/svn-archive/archive.git] / net / gpsd / files / gpsd.hotplug
1 case "$ACTION" in
2 add)
3 # start process
4 # only pl2303 devices are handled
5 if [ "$PRODUCT" = "67b/2303/300" ] && [ "$TYPE" = "0/0/0" ] && [ "$INTERFACE" = "255/0/0" ]; then
6 sleep 3 && /etc/init.d/gpsd start
7 fi
8 ;;
9 remove)
10 # stop process
11 # only pl2303 devices are handled
12 if [ "$PRODUCT" = "67b/2303/300" ] && [ "$TYPE" = "0/0/0" ] && [ "$INTERFACE" = "255/0/0" ]; then
13 /etc/init.d/gpsd stop
14 fi
15 ;;
16 esac