[package] update lftp to 4.0.3, add libexpat dependency (#6206)
[openwrt/svn-archive/archive.git] / net / lftp / patches / 001-libintl.patch
1 diff -burN lftp-3.7.7/lib/gettext.h lftp-3.7.7.patched/lib/gettext.h
2 --- lftp-3.7.7/lib/gettext.h 2008-05-16 18:28:43.000000000 +0200
3 +++ lftp-3.7.7.patched/lib/gettext.h 2009-01-03 18:59:05.374184151 +0100
4 @@ -22,7 +22,6 @@
5 #if ENABLE_NLS
6
7 /* Get declarations of GNU message catalog functions. */
8 -# include <libintl.h>
9
10 /* You can set the DEFAULT_TEXT_DOMAIN macro to specify the domain used by
11 the gettext() and ngettext() macros. This is an alternative to calling
12 @@ -54,7 +53,6 @@
13 #if defined(__cplusplus) && defined(__GNUG__) && (__GNUC__ >= 3)
14 # include <cstdlib>
15 # if (__GLIBC__ >= 2) || _GLIBCXX_HAVE_LIBINTL_H
16 -# include <libintl.h>
17 # endif
18 #endif
19