[packages] lighttpd: update to 1.4.29, add patch for OpenSSL's disabled elliptic...
[openwrt/svn-archive/archive.git] / net / lighttpd / patches / 001-no_ec.patch
1 --- a/src/network.c
2 +++ b/src/network.c
3 @@ -480,9 +480,11 @@ int network_init(server *srv) {
4 network_backend_t backend;
5
6 #if OPENSSL_VERSION_NUMBER >= 0x0090800fL
7 +#ifndef OPENSSL_NO_ECDH
8 EC_KEY *ecdh;
9 int nid;
10 #endif
11 +#endif
12
13 #ifdef USE_OPENSSL
14 DH *dh;