Fix patch fixes the 2.6.19 compilation issues (#1146)
[openwrt/svn-archive/archive.git] / net / nmap / patches / 01-cross_compile.patch
1 #
2 # Just assume pcap version is recent enough when cross-compiling
3 #
4 diff -ruN nmap-4.01-old/configure nmap-4.01-new/configure
5 --- nmap-4.01-old/configure 2006-02-02 03:18:42.000000000 +0100
6 +++ nmap-4.01-new/configure 2006-10-23 22:08:15.000000000 +0200
7 @@ -5765,9 +5765,9 @@
8
9 fi;
10
11 -if test $linux = yes; then
12 - have_libpcap=no
13 -fi
14 +#if test $linux = yes; then
15 +# have_libpcap=no
16 +#fi
17
18 if test $needs_cpp_precomp = yes; then
19 CXXFLAGS="-no-cpp-precomp $CXXFLAGS"
20 @@ -5788,8 +5788,8 @@
21 echo "$as_me:$LINENO: checking if libpcap version is recent enough" >&5
22 echo $ECHO_N "checking if libpcap version is recent enough... $ECHO_C" >&6
23 if test "$cross_compiling" = yes; then
24 - echo "$as_me:$LINENO: result: no" >&5
25 -echo "${ECHO_T}no" >&6; have_libpcap=no
26 + echo "$as_me:$LINENO: result: yes" >&5
27 +echo "${ECHO_T}yes" >&6; have_libpcap=yes
28 else
29 cat >conftest.$ac_ext <<_ACEOF
30 /* confdefs.h. */