valgrind: update to 3.10.1 and fix kernel >= 4.0
[openwrt/svn-archive/archive.git] / package / devel / valgrind / patches / 120-Fix-configure-for-Linux-kernel-4.0-rc1.patch
1 From bf803555d10b5b4c9223b24bf13845ee88d8f3b5 Mon Sep 17 00:00:00 2001
2 From: cborntra <cborntra@a5019735-40e9-0310-863c-91ae7b9d1cf9>
3 Date: Mon, 23 Feb 2015 20:19:03 +0000
4 Subject: [PATCH] Fix configure for Linux kernel >= 4.0-rc1 In addition raise
5 the minimal Linux version to 2.6 as there is almost no test coverage for 2.4
6 and 2.6 was released in 2003.
7
8 git-svn-id: svn://svn.valgrind.org/valgrind/trunk@14955 a5019735-40e9-0310-863c-91ae7b9d1cf9
9 ---
10 NEWS | 3 +++
11 configure.ac | 18 ++++++------------
12 2 files changed, 9 insertions(+), 12 deletions(-)
13
14 --- a/configure.ac
15 +++ b/configure.ac
16 @@ -303,20 +303,14 @@ case "${host_os}" in
17 kernel=${UNAME_R:-`uname -r`}
18
19 case "${kernel}" in
20 - 2.6.*|3.*)
21 - AC_MSG_RESULT([2.6.x/3.x family (${kernel})])
22 - AC_DEFINE([KERNEL_2_6], 1, [Define to 1 if you're using Linux 2.6.x or Linux 3.x])
23 - ;;
24 -
25 - 2.4.*)
26 - AC_MSG_RESULT([2.4 family (${kernel})])
27 - AC_DEFINE([KERNEL_2_4], 1, [Define to 1 if you're using Linux 2.4.x])
28 - ;;
29 -
30 - *)
31 + 0.*|1.*|2.0.*|2.1.*|2.2.*|2.3.*|2.4.*|2.5.*)
32 AC_MSG_RESULT([unsupported (${kernel})])
33 - AC_MSG_ERROR([Valgrind works on kernels 2.4, 2.6])
34 + AC_MSG_ERROR([Valgrind needs a Linux kernel >= 2.6])
35 ;;
36 +
37 + *)
38 + AC_MSG_RESULT([2.6 or later (${kernel})])
39 + ;;
40 esac
41
42 ;;