cyassl: update to wolfssl 3.6.0
[openwrt/svn-archive/archive.git] / package / libs / cyassl / patches / 400-additional_compatibility.patch
1 --- a/cyassl/openssl/ssl.h
2 +++ b/cyassl/openssl/ssl.h
3 @@ -24,4 +24,13 @@
4 *
5 */
6
7 +#ifndef CYASSL_OPENSSL_H_
8 +#define CYASSL_OPENSSL_H_
9 +
10 +#include <cyassl/ssl.h>
11 +#ifndef HAVE_SNI
12 +#undef CYASSL_SNI_HOST_NAME
13 +#endif
14 #include <wolfssl/openssl/ssl.h>
15 +
16 +#endif