[package] lua: add zlib build dependency, fix inaccuracy in gzip loader
[openwrt/svn-archive/archive.git] / package / lua / patches-host / 015-lnum-ppc-compat.patch
1 Index: lua-5.1.3/src/lua.h
2 ===================================================================
3 --- lua-5.1.3.orig/src/lua.h 2008-06-29 11:45:55.000000000 +0200
4 +++ lua-5.1.3/src/lua.h 2008-06-29 11:46:28.000000000 +0200
5 @@ -79,7 +79,7 @@
6 * not acceptable for 5.1, maybe 5.2 onwards?
7 * 9: greater than existing (5.1) type values.
8 */
9 -#define LUA_TINT (-2)
10 +#define LUA_TINT 9
11
12 #define LUA_TNIL 0
13 #define LUA_TBOOLEAN 1