[package] lua: add zlib build dependency, fix inaccuracy in gzip loader
[openwrt/svn-archive/archive.git] / package / lua / patches-host / 100-no_readline.patch
1 diff -ur lua-luci-5.1.3/src/luaconf.h lua-luci-5.1.3-new/src/luaconf.h
2 --- lua-luci-5.1.3/src/luaconf.h 2008-04-14 13:19:54.000000000 +0200
3 +++ lua-luci-5.1.3-new/src/luaconf.h 2008-04-14 13:19:17.000000000 +0200
4 @@ -38,7 +38,6 @@
5 #if defined(LUA_USE_LINUX)
6 #define LUA_USE_POSIX
7 #define LUA_USE_DLOPEN /* needs an extra library: -ldl */
8 -#define LUA_USE_READLINE /* needs some extra libraries */
9 #endif
10
11 #if defined(LUA_USE_MACOSX)
12 Nur in lua-luci-5.1.3-new/src: luaconf.h.orig.
13 diff -ur lua-luci-5.1.3/src/Makefile lua-luci-5.1.3-new/src/Makefile
14 --- lua-luci-5.1.3/src/Makefile 2008-04-14 13:19:57.000000000 +0200
15 +++ lua-luci-5.1.3-new/src/Makefile 2008-04-14 13:19:17.000000000 +0200
16 @@ -17,6 +17,7 @@
17 MYCFLAGS=
18 MYLDFLAGS=
19 MYLIBS=
20 +# USE_READLINE=1
21
22 # == END OF USER SETTINGS. NO NEED TO CHANGE ANYTHING BELOW THIS LINE =========
23
24 @@ -86,7 +87,7 @@
25 @echo "MYLIBS = $(MYLIBS)"
26
27 # convenience targets for popular platforms
28 -
29 +RFLAG=$(if $(USE_READLINE),-DLUA_USE_READLINE)
30 none:
31 @echo "Please choose a platform:"
32 @echo " $(PLATS)"
33 @@ -101,16 +102,16 @@
34 $(MAKE) all MYCFLAGS="-DLUA_USE_POSIX -DLUA_USE_DLOPEN" MYLIBS="-Wl,-E"
35
36 freebsd:
37 - $(MAKE) all MYCFLAGS="-DLUA_USE_LINUX" MYLIBS="-Wl,-E -lreadline"
38 + $(MAKE) all MYCFLAGS="-DLUA_USE_LINUX $(RFLAG)" MYLIBS="-Wl,-E$(if $(USE_READLINE), -lreadline)"
39
40 generic:
41 $(MAKE) all MYCFLAGS=
42
43 linux:
44 - $(MAKE) all MYCFLAGS+=-DLUA_USE_LINUX MYLIBS="-Wl,-E -ldl -lreadline -lhistory -lncurses"
45 + $(MAKE) all MYCFLAGS+="-DLUA_USE_LINUX $(RFLAG)" MYLIBS="-Wl,-E -ldl $(if $(USE_READLINE), -lreadline -lhistory -lncurses)"
46
47 macosx:
48 - $(MAKE) all MYCFLAGS=-DLUA_USE_LINUX MYLIBS="-lreadline"
49 + $(MAKE) all MYCFLAGS=-DLUA_USE_LINUX $(if $(USE_READLINE), MYLIBS="-lreadline")
50 # use this on Mac OS X 10.3-
51 # $(MAKE) all MYCFLAGS=-DLUA_USE_MACOSX
52
53 Nur in lua-luci-5.1.3-new/src: Makefile.orig.