[package] add explicit dependency on kmod-crypto-core when required (closes: #6557)
[openwrt/svn-archive/archive.git] / package / ubsec_ssb / Makefile
1 #
2 # Copyright (C) 2008 OpenWrt.org
3 #
4 # This is free software, licensed under the GNU General Public License v2.
5 # See /LICENSE for more information.
6 #
7
8 include $(TOPDIR)/rules.mk
9 include $(INCLUDE_DIR)/kernel.mk
10
11 PKG_NAME:=ubsec-ssb
12 PKG_VERSION:=2009-02-21
13
14 CRYPTO_MENU:=OCF Configuration
15
16 include $(INCLUDE_DIR)/package.mk
17
18 define KernelPackage/ocf-ubsec-ssb
19 SUBMENU:=$(CRYPTO_MENU)
20 DEPENDS:=@TARGET_brcm47xx +kmod-crypto-core +kmod-crypto-ocf
21 TITLE:=BCM5365P IPSec Core driver
22 FILES:=$(PKG_BUILD_DIR)/src/ubsec_ssb.$(LINUX_KMOD_SUFFIX)
23 AUTOLOAD:=$(call AutoLoad,09,ubsec_ssb)
24 endef
25
26 define KernelPackage/ocf-ubsec-ssb/description
27 This package contains the OCF driver for the BCM5365p IPSec Core
28 endef
29
30 define Build/Prepare
31 mkdir -p $(PKG_BUILD_DIR)
32 $(CP) -r ./src $(PKG_BUILD_DIR)/
33 endef
34
35 LINUX_PATCHLEVEL:=$(shell echo "$(LINUX_VERSION)" | cut -d. -f2)
36
37 define Build/Compile
38 $(MAKE) -C $(LINUX_DIR) \
39 ARCH="$(LINUX_KARCH)" \
40 CROSS_COMPILE="$(TARGET_CROSS)" \
41 PATCHLEVEL="$(LINUX_PATCHLEVEL)" \
42 KERNDIR="$(LINUX_DIR)" \
43 SUBDIRS="$(PKG_BUILD_DIR)/src" \
44 modules
45 endef
46
47 $(eval $(call KernelPackage,ocf-ubsec-ssb))