[adm5120] restore right patches for 2.6.21.5
[openwrt/svn-archive/archive.git] / target / linux / adm5120-2.6 / patches / 006-adm5120_leds.patch
1 Index: linux-2.6.21.1/drivers/leds/Kconfig
2 ===================================================================
3 --- linux-2.6.21.1.orig/drivers/leds/Kconfig
4 +++ linux-2.6.21.1/drivers/leds/Kconfig
5 @@ -19,6 +19,27 @@ config LEDS_CLASS
6
7 comment "LED drivers"
8
9 +config LEDS_GPIO
10 + tristate "LED support for LEDS on GPIO lines"
11 + depends on LEDS_CLASS && GENERIC_GPIO
12 + help
13 + This option enables support for LEDs connected to GPIO lines
14 +
15 +config LEDS_ADM5120
16 + tristate "LED Support for ADM5120 GPIO LEDs"
17 + depends on LEDS_GPIO && MIPS_ADM5120
18 + help
19 + This option enables support for LEDs connected to GPIO lines
20 + on ADM5120 SoC based platforms.
21 +
22 +config LEDS_ADM5120_EXPERIMENTAL
23 + bool "Enable ADM5120 LEDs experimental code"
24 + depends on LEDS_ADM5120
25 +
26 +config LEDS_ADM5120_DIAG
27 + bool "Enable ADM5120 LEDs diagnostic mode"
28 + depends on LEDS_ADM5120
29 +
30 config LEDS_CORGI
31 tristate "LED Support for the Sharp SL-C7x0 series"
32 depends on LEDS_CLASS && PXA_SHARP_C7xx
33 Index: linux-2.6.21.1/drivers/leds/Makefile
34 ===================================================================
35 --- linux-2.6.21.1.orig/drivers/leds/Makefile
36 +++ linux-2.6.21.1/drivers/leds/Makefile
37 @@ -5,6 +5,8 @@ obj-$(CONFIG_LEDS_CLASS) += led-class.o
38 obj-$(CONFIG_LEDS_TRIGGERS) += led-triggers.o
39
40 # LED Platform Drivers
41 +obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
42 +obj-$(CONFIG_LEDS_ADM5120) += leds-adm5120.o
43 obj-$(CONFIG_LEDS_CORGI) += leds-corgi.o
44 obj-$(CONFIG_LEDS_LOCOMO) += leds-locomo.o
45 obj-$(CONFIG_LEDS_SPITZ) += leds-spitz.o