[ar71xx] add initial support for 2.6.29
[openwrt/svn-archive/archive.git] / target / linux / ar71xx / patches-2.6.29 / 004-ar71xx_spi_controller.patch
1 --- a/drivers/spi/Kconfig
2 +++ b/drivers/spi/Kconfig
3 @@ -53,6 +53,13 @@ if SPI_MASTER
4
5 comment "SPI Master Controller Drivers"
6
7 +config SPI_AR71XX
8 + tristate "Atheros AR71xx SPI Controller"
9 + depends on SPI_MASTER && ATHEROS_AR71XX
10 + select SPI_BITBANG
11 + help
12 + This is the SPI contoller driver for Atheros AR71xx.
13 +
14 config SPI_ATMEL
15 tristate "Atmel SPI Controller"
16 depends on (ARCH_AT91 || AVR32)
17 --- a/drivers/spi/Makefile
18 +++ b/drivers/spi/Makefile
19 @@ -11,6 +11,7 @@ endif
20 obj-$(CONFIG_SPI_MASTER) += spi.o
21
22 # SPI master controller drivers (bus)
23 +obj-$(CONFIG_SPI_AR71XX) += ar71xx_spi.o
24 obj-$(CONFIG_SPI_ATMEL) += atmel_spi.o
25 obj-$(CONFIG_SPI_BFIN) += spi_bfin5xx.o
26 obj-$(CONFIG_SPI_BITBANG) += spi_bitbang.o