fix sysupgrade support for brcm-2.4 and brcm47xx
[openwrt/svn-archive/archive.git] / target / linux / brcm-2.4 / base-files / lib / upgrade / platform.sh
1 PART_NAME=linux
2
3 platform_check_image() {
4 [ "$ARGC" -gt 1 ] && return 1
5
6 case "$(get_magic_word "$1")" in
7 # .trx files
8 4844) return 0;;
9 *)
10 echo "Invalid image type. Please use only .trx files"
11 return 1
12 ;;
13 esac
14 }
15
16 # use default for platform_do_upgrade()