[gemini]: upgrade to 3.9-rc4, disable unsupported boards
[openwrt/svn-archive/archive.git] / target / linux / gemini / patches / 132-arm-gemini-wbd111-register-usb.patch
1 --- a/arch/arm/mach-gemini/board-wbd111.c
2 +++ b/arch/arm/mach-gemini/board-wbd111.c
3 @@ -145,6 +145,7 @@ static void __init wbd111_init(void)
4 platform_register_watchdog();
5 platform_device_register(&wbd111_phy_device);
6 platform_register_ethernet(&gmac_data);
7 + platform_register_usb(0);
8 }
9
10 MACHINE_START(WBD111, "Wiliboard WBD-111")
11 --- a/drivers/usb/host/ehci-hcd.c
12 +++ b/drivers/usb/host/ehci-hcd.c
13 @@ -99,7 +99,11 @@ module_param (park, uint, S_IRUGO);
14 MODULE_PARM_DESC (park, "park setting; 1-3 back-to-back async packets");
15
16 /* for flakey hardware, ignore overcurrent indicators */
17 +#ifdef CONFIG_ARCH_GEMINI
18 +static bool ignore_oc = 1;
19 +#else
20 static bool ignore_oc = 0;
21 +#endif
22 module_param (ignore_oc, bool, S_IRUGO);
23 MODULE_PARM_DESC (ignore_oc, "ignore bogus hardware overcurrent indications");
24