update iptables to 1.4.0 (2.6 kernels only), refresh kernel patches
[openwrt/svn-archive/archive.git] / target / linux / generic-2.6 / patches-2.6.23 / 401-led_alix.patch
1 diff -Nur linux-2.6.23.1.orig/drivers/leds/Kconfig linux-2.6.23.1/drivers/leds/Kconfig
2 --- linux-2.6.23.1.orig/drivers/leds/Kconfig 2007-10-12 12:43:44.000000000 -0400
3 +++ linux-2.6.23.1/drivers/leds/Kconfig 2007-10-31 02:36:22.000000000 -0400
4 @@ -81,6 +81,12 @@
5 help
6 This option enables support for the PCEngines WRAP programmable LEDs.
7
8 +config LEDS_ALIX
9 + tristate "LED Support for the ALIX 2/3 boards"
10 + depends on LEDS_CLASS
11 + help
12 + This option enables support for the three LEDs on the PCEngines ALIX 2/3 boards.
13 +
14 config LEDS_H1940
15 tristate "LED Support for iPAQ H1940 device"
16 depends LEDS_CLASS && ARCH_H1940
17 diff -Nur linux-2.6.23.1.orig/drivers/leds/Makefile linux-2.6.23.1/drivers/leds/Makefile
18 --- linux-2.6.23.1.orig/drivers/leds/Makefile 2007-10-12 12:43:44.000000000 -0400
19 +++ linux-2.6.23.1/drivers/leds/Makefile 2007-10-31 02:36:17.000000000 -0400
20 @@ -14,6 +14,7 @@
21 obj-$(CONFIG_LEDS_AMS_DELTA) += leds-ams-delta.o
22 obj-$(CONFIG_LEDS_NET48XX) += leds-net48xx.o
23 obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
24 +obj-$(CONFIG_LEDS_ALIX) += leds-alix.o
25 obj-$(CONFIG_LEDS_H1940) += leds-h1940.o
26 obj-$(CONFIG_LEDS_COBALT) += leds-cobalt.o
27 obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o