[toolchain/binutils]: add binutils 2.21
[openwrt/svn-archive/archive.git] / toolchain / binutils / Config.in
1 # Choose binutils version.
2
3 choice
4 prompt "Binutils Version" if TOOLCHAINOPTS
5 default BINUTILS_VERSION_2_19_1 if ubicom32
6 default BINUTILS_VERSION_2_20_1
7 help
8 Select the version of binutils you wish to use.
9
10 config BINUTILS_VERSION_2_19_1
11 bool "binutils 2.19.1"
12
13 config BINUTILS_VERSION_2_20_1
14 depends !ubicom32
15 bool "binutils 2.20.1"
16
17 config BINUTILS_VERSION_2_21
18 depends !ubicom32
19 bool "binutils 2.21"
20
21 config BINUTILS_VERSION_CS
22 depends !avr32
23 depends !ubicom32
24 depends BROKEN
25 bool "binutils 2.19.1+20090205 with CodeSourcery enhancements"
26
27 endchoice
28
29 config EXTRA_BINUTILS_CONFIG_OPTIONS
30 string
31 prompt "Additional binutils configure options" if TOOLCHAINOPTS
32 default ""
33 help
34 Any additional binutils options you may want to include....
35
36 config BINUTILS_VERSION
37 string
38 prompt "Binutils Version" if (TOOLCHAINOPTS && NULL)
39 default "2.19.1" if BINUTILS_VERSION_2_19_1
40 default "2.20.1" if BINUTILS_VERSION_2_20_1
41 default "2.21" if BINUTILS_VERSION_2_21
42 default "2.19.1+cs" if BINUTILS_VERSION_CS
43 default "2.19.1" if ubicom32
44 default "2.20.1"